Support » Localhost Installs » Error establishing a database connection

Viewing 5 replies - 1 through 5 (of 5 total)
  • Your database connection details are not correct in your wp-config.php. However they must have been correct at some point in order to install wordpress.

    Have you gone through the WP install process? If you have did everything go OK? Did the WP install ask you to cut and paste some code into the wp-config.php?

    If you open up wp-config.php(which can be found in the wordpress folder) you should see entries for :-

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘xxxxxxxxxxx’);

    /** MySQL database username */
    define(‘DB_USER’, ‘xxxxxxxxxxx’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘xxxxxxxxxx’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘xxxxxxxx’);

    where the xxxxx’s are values specific to your database.

    If these values are not correct then you will not be able to get a database connection

    There are instructions for several methods of changing the URL’s back located here: Changing The Site URL Please read carefully before deciding which method will be best for your site.

    1) Check your database connection maybe details are not correct in your wp-config.php.
    2) Maybe you did not assign a user to your database and did assign complete privileges.

    Like & share if this solved your issues: Fiver | http://www.arcube.net

    Okay, just for a little clarity..

    A) You changed the URL on a ‘localhost’ install from your dashboard settings – does that mean you changed the URLs on a local machine in the hope that it would resolve the new name to that WordPress site? If so, then use the information I pointed you to in my first reply to change the URL’s back and get your localhost site back up and running.

    B) ‘auctusgroup.co.za’ is a live site being hosted by About IT Online, and it has a configuration issue. If what you actually did when you say you “went to settings and changed http://localhost/auctusgroup to http://auctusgroup.co.za
    was to move a local development site to a live server in an effort to make it live, then have a look at these instructions: Moving WordPress. That information can help you move the site properly, if that was your intention.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error establishing a database connection’ is closed to new replies.