Support » Installing WordPress » Error establishing a database connection

  • I keep getting the following error message

    “Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at localhost. This could mean your host’s database server is down.
    • Are you sure you have the correct username and password?
    • Are you sure that you have typed the correct hostname?
    • Are you sure that the database server is running?
    If you’re unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.”

    I have looked at the following video links to provide guidance, but neither of their approaches have worked.

    I have uploaded the wordpress files to the blog database in the public_html directory after editing the config.php file – i have tried a number of permutations

    a) keeping the local host and all other names, user names and password
    b) changing the database name and username and password to that of the remote host while keeping the local host as the msql host name
    c) changing all the data inputs to that of the host site

    I have checked with my host provider that the remote host data and names i am using are correct.

    But to no avail. None of the videos, none of the installers, be it filezilla or others and none of the docs i have read give me an inkling as to what is wrong….

Viewing 4 replies - 1 through 4 (of 4 total)
  • hi

    It is strange but since this morning i have been getting the same error message and my wordpress site was up and running for n few weeks already. I have also contacted my service provider and everything is fine on their side.
    I hope this is a wordpress error which will be fixed as soon as possible because I have no idea what to do anymore.

    I would be willing to help off forum if you want to email me
    srb333 at att dot net

    log in to your host’s phpmyadmin
    select correct database
    check mark all tables
    scroll to bottom and choose “repair” from drop down
    blog should now work

    After something like a week or more of trying to get this done, and after reviewing countless options, it appears the problem is this according to my host provider “WordPress is configured correctly, but it appears the server doesn’t have the proper routing information for the domain”

    It is now working……………..

    Installing wordpress is a bit like skimming the surface of a vast ocean – as soon as you need to know what is going on underneath you are toast unless you are an oceanographer.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error establishing a database connection’ is closed to new replies.