Support » Networking WordPress » Error establishing a database connection

  • Resolved bhakti3


    I am trying to create a network. Single user site was working OK, but in attempt to login after Network install I get this error:

    Error establishing a database connection

    Running diagnostic I get this:

    wp_1_posts: Table ‘wpmu.wp_1_posts’ doesn’t exist
    wp_1_comments: Table ‘wpmu.wp_1_comments’ doesn’t exist
    wp_1_links: Table ‘wpmu.wp_1_links’ doesn’t exist
    wp_1_options: Table ‘wpmu.wp_1_options’ doesn’t exist
    wp_1_postmeta: Table ‘wpmu.wp_1_postmeta’ doesn’t exist
    wp_1_terms: Table ‘wpmu.wp_1_terms’ doesn’t exist
    wp_1_term_taxonomy: Table ‘wpmu.wp_1_term_taxonomy’ doesn’t exist
    wp_1_term_relationships: Table ‘wpmu.wp_1_term_relationships’ doesn’t exist
    wp_1_commentmeta: Table ‘wpmu.wp_1_commentmeta’ doesn’t exist

    MySQL user has ALL privileges

    Plugins were disabled on second attempt at Network install

    I have read other threads, but have not found solution to my problem here.

    Any help would be great.



Viewing 15 replies - 1 through 15 (of 17 total)
  • Did you follow the instructions in this codex article to create your network? Based on the errors you received, it looks almost as though you tried to install an old version of WPMU overtop of an existing installation of WordPress.

    And it shouldn’t be looking for wp_1 anything. That doesn’t exist anymore.

    Thanks for your replies:

    I installed WP 3.1 and then followed the codex to which you make reference.

    Certainly the tables wp_1_XXXX don’t exist any more; I checked. Not sure if they ever existed?

    Some tables have been created like wp_signups and wp_site and others peculiar to WPMU Db. (NOt a privileges issue then)

    Seems that wherever there is ‘_1_’, the table does not exist/ was not created in first place.


    The diagnostic is wrong. Or rather it’s pointing to the wrong thing.

    What did you add to your wp-config.php file?

    define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, true );
    $base = ‘/wp-mu/’;
    define( ‘DOMAIN_CURRENT_SITE’, ‘’ );
    define( ‘PATH_CURRENT_SITE’, ‘/wp-mu/’ );
    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    I have a feeling it maybe to do with fact I need special plugin to map domain names in WPMU.

    I have gone into settings and changed the URL’s accordingly to

    , but it still uses the domain in the code given for wp-config.php.

    Maybe I have to go into edit httpd.conf to totally disassociate WP from the domain.

    I may also have to delete all extraneous WPMU Db tables before I reinstall network?

    You didn’t add this?

    define('WP_ALLOW_MULTISITE', true);

    Cause if you read this:

    You should add that FIRST and then go through the network steps.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    I have a feeling it maybe to do with fact I need special plugin to map domain names in WPMU.

    remove it.

    You cannot map domains or do anything with multisite until you have the network installed and working properly.

    OK Thank you!

    It was not the domain name. Running a VS I had to register a domain name to work with. No fear, I checked with my ISP, who confirmed other clients had successfully set up WPMU.

    A great believer in human error 😉 … I found that I had, in a pasting frenzie, replaced:

    define(‘WP_ALLOW_MULTISITE’, true);


    define( ‘MULTISITE’, true );

    …not seing the er…now not so subtle differences and thinking they were the same.

    One part of the solution, like rebooting a PC, was to start from scratch again, having saved my config and .htaccess file and dropped all Db tables 🙂

    I can only say thank you for the help you’ve made available to me.


    Yeah, actually you may need both (can’t remember… I have both cause my install’s a bit old).

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    You do need both. While this one:

    define(‘WP_ALLOW_MULTISITE’, true);

    is only there to generate the network creation menu, some people have recommended removing it, but,

    – I like having the network menu still there (gives access to rewrite rules in case they get hosed)
    – people who see instructions to remove it invariably remove the wrong line

    So. I tell people to keep both of ’em in there.

    I’ve an installation that’s been running fine for some time with four blogs. Today I went to add a new one and the backend indicated that it was successful. I then tried to go to the blog and received this lovely message “Error establishing a database connection”. I tried going to the dashboard for the site and received a message that there might be something wrong with the database and it suggested that I add a line to my config file to allow WP to try and fix the problem. I did so and reloaded the page as suggested and it attempted to repair the DB but failed giving this as the output and telling me to post it in a support forum!!! So here I am:

    aaaWpMu_6_posts: Table ‘earthsociety_WPMUCore27Oct2010.aaaWpMu_6_posts’ doesn’t exist
    aaaWpMu_6_comments: Table ‘earthsociety_WPMUCore27Oct2010.aaaWpMu_6_comments’ doesn’t exist
    aaaWpMu_6_links: Table ‘earthsociety_WPMUCore27Oct2010.aaaWpMu_6_links’ doesn’t exist
    aaaWpMu_6_options: Table ‘earthsociety_WPMUCore27Oct2010.aaaWpMu_6_options’ doesn’t exist
    aaaWpMu_6_postmeta: Table ‘earthsociety_WPMUCore27Oct2010.aaaWpMu_6_postmeta’ doesn’t exist
    aaaWpMu_6_terms: Table ‘earthsociety_WPMUCore27Oct2010.aaaWpMu_6_terms’ doesn’t exist
    aaaWpMu_6_term_taxonomy: Table ‘earthsociety_WPMUCore27Oct2010.aaaWpMu_6_term_taxonomy’ doesn’t exist
    aaaWpMu_6_term_relationships: Table ‘earthsociety_WPMUCore27Oct2010.aaaWpMu_6_term_relationships’ doesn’t exist
    aaaWpMu_6_commentmeta: Table ‘earthsociety_WPMUCore27Oct2010.aaaWpMu_6_commentmeta’ doesn’t exist

    Any thoughts? Do I need to rebuild my entire database? What caused this in the first place? . . . (time passes) . . . I’ve deleted the defective blog-site and tried again with the same result. For some reason the tables aren’t being created. Where can I access relevant log files? I don’t have access to server logs, are there logs made by WP?

    If I create these tables in ‘phpmyadmin’, would wordpress then be able to add the appropriate fields? Maybe there is a way to copy the existing functional sites then clean them out? Rebuilding from scratch seems like a lot of work, and I’m terribly lazy.

    First, check to see if the tables DO exist. If NOT, did you have an active blog 6? it looks like either they did not get created, or they were deleted.

    They don’t exist. I’ve deleted the site and re-tried several times, each time it increments the number (currently on #9). It is creating some of the tables however:


    Those tables are in the DB, the others as listed in previous post do not. I’m using WP 3.0.5 if that helps.

    As the tables being created are related to a plugin, perhaps that plugin is the problem. Will disable and test again.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Error establishing a database connection’ is closed to new replies.