Support » Installing WordPress » Error establishing a database connection

  • I’m trying to make WordPress run locally on my PC but have problems setting it up. (I tried to look at the many many posts on this subject, but couldn’t find a solution for myself…)

    – MySQL 5.0
    – PHP 4.4.1
    – hosted on my pc (using IIS).

    I created a database named ‘wordpress’ and I can connect to it from within the mysql shell, but for some reason WordPress just couldn’t connect to it. I’m sure the dbname, dbpassword, and dbhost are correct.

    I tinkered with the wordpress php source to find out the problem and I managed to get it to print out this error message:

    “WordPress database error: [Client does not support authentication protocol requested by server; consider upgrading MySQL client]”

    I installed MySQL using default settings.
    Any help? What else should I look for? Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • i think best way to start using php and mysql on local is by using easyphp it will install php , mysql and phpMyadmin its a very nice and free software

    i know this might not answer your question … but it can help you alot dealing with mysql and php

    here is the link for easyphp :

    Hi, no it doesn’t answer my question, but it gave me the idea to try and see first if my PHP installation works with MySQL independent of WordPress. Thanks.

    Setting up a server (even a local one) is not something that should be discussed on the WP Forum because it is not a WP issue. I assume there are many specialized sites/fora for this kind of questions, so please, ask there.

    Moderator James Huff


    We are getting this same error:
    “We were able to connect to the database server (which means your username and password is okay) but not able to select the mysite_wordpress database.”

    The database certainly exists.
    And I have the correct name with the prefix in wp-config.php

    Where do we go from here?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error establishing a database connection’ is closed to new replies.