WordPress.org

Forums

Error establishing a database connection (13 posts)

  1. primowalker
    Member
    Posted 10 years ago #

    I editied the wp-config.php file and entered the correct information for the database, user and password. I check mysql and the database and user infor is correct and mysql is running, but I'm still getting the error "Error establishing a database connection" when trying to run install.php. My OS is Solaris 9. The permissions on all of the files in the wordress directory are 777.

  2. MichaelH
    Member
    Posted 10 years ago #

  3. Myword
    Member
    Posted 10 years ago #

    I am having exactly the same issue..I suspect that the database is not turned on. http://www.disyasite.com/weblog/wp-admin/install.php

    Is that screen the same as your getting?

    I'd be interested in any solution you find, I have already questioned my ISP who is adamant it is on..should there be some files visible in the data folder? the answer was NO..I'm stumped.

  4. moshu
    Member
    Posted 10 years ago #

    Myword,
    how did you get the 4 pieces of info needed for the config file that you posted in the other thread? Did the host give it to you? Was the DB created by yourself?

  5. Myword
    Member
    Posted 10 years ago #

    Host supplied the 4 peices and they set up the mysql..

  6. Myword
    Member
    Posted 10 years ago #

    I contacted my host today who once again is insistent that the MYSQL is set up and ready.

    Does wordpress demand the existence of an apache module to run???

    My hosting is on an NT server that is not runing apache mods...

    I'm wondering if this is really my problem. I was told that wordpress would run properly on an NT server.

  7. Myword
    Member
    Posted 10 years ago #

    My host kept on insisting I upload the wordpress database to the folder myself...I wonder where the database is supposed to come from? I gather the install routine of wordpress creates the database itself...Is that correct?

  8. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Myword - you have 2 threads going. I'd suggest starting a new one and summarising your problems - it will be easier to get help that way.

  9. Myword
    Member
    Posted 10 years ago #

    To distill the question "Can I run wordpress on an NT server without the apache module?"

  10. Myword
    Member
    Posted 10 years ago #

    Thanks ..will the new thread appear in my profile?

  11. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Yes.

  12. Myword
    Member
    Posted 10 years ago #

    HOW DO I START A NEW THREAD MYSELF? (I'm real new here sorry!)

  13. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Scroll to the bottom of this page:
    http://wordpress.org/support/forum/2

Topic Closed

This topic has been closed to new replies.

About this Topic