• Resolved Amanda

    (@rocketkiddo)


    Hello, when I have your plugin activated Health Check & Troubleshooting Plugin detects the following Critical Error:

    Loopback requests are used to run scheduled events and are also used by the built-in editors for themes and plugins to verify code stability.
    
    The loopback request to your site failed, this means features relying on them are not currently working as expected.
    Error encountered: (0) cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received

    This has been reported in the past and fixed but it seems it occurs for me again.

    Could anyone take a look, please?

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi @rocketkiddo

    I hope you’re well today and thank you for reporting this!

    I’m also aware of the previous case which was over a year ago. Not being a developer myself, I’m not quite sure what exactly was changed in plugin’s code back then but we didn’t have similar reports since the fixed version was released.

    I’ve now tired to replicate it on one of my test sites, then on a separate clean installation and I’ve also asked one of my colleagues to test – but we weren’t able to replicate this.

    I understand that you can confirm that the Custom Sidebars plugin is causing it and if you disable the plugin, the issue is gone, correct?

    Would you let us know, please, a bit more about your setup: WordPress version, PHP version, is it Apache or nginx or other webserver and on what operating system?

    Also: what’s the PHP max_execution time and memory_limit value and if you’re using default WP_CRON or the server cron instead? What theme are you using for the site?

    Let us know, please.

    Best regards,
    Adam

    Thread Starter Amanda

    (@rocketkiddo)

    Hello @wpmudev-support8

    Thank you so much for your fast response, your support is awesome.

    Well, I’ve got everything, Apache, PHP, WordPress up to date, the server is operating on Linux.

    I have increased the memory_limit up to 256M

    It doesn’t have anything with the theme.
    With everything disabled, the error didn’t show up. Then I had only Custom Sidebars Plugin enabled and the error showed up in Health Check & Troubleshooting reports.

    And yes, if I disable the plugin the error no longer shows up.

    I even have cURL module to the latest version.

    Any thoughts?

    • This reply was modified 4 years, 1 month ago by Amanda.
    • This reply was modified 4 years, 1 month ago by Amanda.

    Hi @rocketkiddo

    Thanks for response and I’m sorry for delay on our end.

    I must say I’m not sure what might be causing it in this case. I tried to replicate this again on a different site and still couldn’t.

    Granted, I only tested it with nothing else but default WordPress installation with Twenty Twenty theme and only Custom Sidebars plugin active. Then with Health Check & Troubleshooting plugin additionally enabled.

    If you switch theme to Twenty Twenty from your current theme and disable absolutely all other plugins (except for Custom Sidebars), including Health Check & Troubleshooting plugin (as WordPress already has Site Health tool built-in) – is it still happening?

    What if you temporarily remove the .htaccess file (just rename it to something else for a moment, for testing)?

    Best regards,
    Adam

    Thread Starter Amanda

    (@rocketkiddo)

    Hello again,

    Just did everything you said

    See the below image

    https://ibb.co/RT2071Q

    Even with the .htaccess deleted the error still shows

    Hello @rocketkiddo

    I trust you are doing well!

    Would you please try deactivating PHP sessions from Custom Sideboards? Add this line to the wp-config.php file:
    define( 'WDEV_USE_SESSION', false );

    Please let us know if this has resolved the issue.

    Kind regards,
    Nastia

    Thread Starter Amanda

    (@rocketkiddo)

    Hello @wpmudev-support9

    I have done what you suggested and the error still shows up.

    Thank you.

    Hello @rocketkiddo

    I trust you are doing well!

    The loopback check itself is simply a remote post to your admin URL. Warning that is shown might the related to PHP sessions, which is triggered only on admin pages.

    I could not replicate this error on my end. It looks like this is happening only on your end. Would you please enable debug mode?

    Add these lines to the wp-config.php file:

    /** Debug **/
    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false ); 

    If there is a connection error that is preventing the loopback from working, it will be shown in the wp-content/debug.log.

    Information from debug.log should give some clues as to what is causing it. It could simply be a memory limit error or timeout.

    Please advise,

    Kind regards,
    Nastia

    Hello @rocketkiddo

    It’s been a while since we’ve heard back from you, so I’m marking this topic as resolved. Feel free to post back any updates and we’ll carry on troubleshooting.

    Take care,
    Dimitris

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Error encountered: (0) cURL error 28 while Custom Sidebars is active’ is closed to new replies.