Support » Plugin: Machete » Error en widgets HTML

  • Hola Nilo, antes que nada felicitarte por tu plugin y decirte que he detectado un problema que me ocurre al activar la opción de “Aplazar el JavaScript”.
    En cuanto la activo me resulta imposible editar los widgets de HTML, aunque siguen funcionando correctamente, pero sin embargo no me muestra el código y por lo tanto no lo puedo editar.
    Si desactivo la opción Aplazar el JavaScript, todo vuelve a la normalidad y me muestra el contenido y lo puedo editar.
    Saludos

    • This topic was modified 2 years, 7 months ago by pacosilva.
Viewing 1 replies (of 1 total)
  • Plugin Author Nilo Velez

    (@nilovelez)

    Hola Paco,
    lo que dices es completamente normal. Hay funciones de Machete que te dejan desactivar cosas que a veces son necesarias, y hay que ir probando en cada situación.

    Por ejemplo, la opción de quitar JQuery-migrate normalmente no da problemas, pero hay temas que fallan estrepitosamente. O la opción de desactivar el JSON-API hace que Gutemberg directamente no cargue.

    En tu caso, una opción es simplemente desactivar la opción, editar el widget y volver a activarlo. Si necesitas más control sobre qué scripts no quieres mover al pie, puedes probar con plugins como Autoptimize, que te dejan excluir ficheros.

Viewing 1 replies (of 1 total)
  • The topic ‘Error en widgets HTML’ is closed to new replies.