Support » Plugin: W3 Total Cache » Error: Empty hostname for MaxCDN Test

  • I updated W3 Total Cache to the latest version (0.9.3) and didn’t change any settings. However, when I click the button to test MaxCDN it now says: Error: Empty hostname

    The “Replace site’s hostname” fields are filled in with the matching c-names from MaxCDN. Please let me know what I can check to see why I am receiving this error now.

Viewing 15 replies - 1 through 15 (of 22 total)
  • I got exactly the same problem.

    Images that I upload right now are not shown on the my website also.

    When I go to the url of the image I must fill in a captcha on the MaxCDN site which leads to… nothing!

    I can keep filling in the box but nothing happens.

    Same thing here. I tried Cloudfront, and W3 Total Cache kept giving me the ERROR: Empty Access Key. That was really strange, because it didn’t have any trouble accessing my account and creating the distribution. Even tried opening a new AWS account, but still had the same issue.

    So, I signed up for MaxCDN, and I get ERROR: Empty hostname. Using the latest WP 3.6 and latest W3 Total Cache.

    Me too. Mine had no problem with the test until updating to the new W3 Total Cache. Now I get a red box containing “Error: Empty hostname”.

    Wish we didn’t have this problem, but glad that it’s likely not our configuration(s).

    We are also running WP 3.6 and the latest version of W3 Total Cache v0.9.3

    Simple solution for now is to downgrade back to version

    Just unzip the package and overwrite all the files in your current wp-content/plugins/w3-total-cache directory. It will work all fine.

    What is the lesson?

    Never update immediately when it comes to W3TC. Just wait another 1 or 2 weeks and a newer version will probably already be available which fixed a lot of bugs of the version before that.

    Here is a similar thread dealing with the same error but pertaining to the use of AWS Cloudfront rather than MaxCDN:

    I got the same problem.

    Is there a real solution to the problem yet or is there an update around the corner?



    I have the same problem .. the hostname is there and my CNAME is working but I get this error : Error: Empty hostname

    This plugin really has a poor support

    Same problem here. Hopefully there’s a bug fix soon.

    I’m trying to connect MAXcdn for the very first time… after a good hour of head scratching, i’m hoping that its the same problem that everyone on this thread is suffering…

    Any tips or tricks about getting me going much appreciated!

    I get the same error, but it doesn’t seem to affect it working properly.

    i got same error, for some sites, and some sites would work perfectly

    when i go to the plugin overview page on all the sites though, the maxcdn/netdna stats display correctly however so it seems its a possible fail in the tester rather than anything more serious (cant confirm at this stage though)

    Anyone that still has CDN issues, I posted a working solution until this is resolved.

    The error is just on the test. The CDN is actually working in my case. You have to ignore the test button and instead save your changes and then view the source of your website. You should see some content pulling from MAXcdn. I did.


    Good for you 🙂

    It seems to be a 50/50 issue, and I was hoping to be on the 50 side that works like yourself, but when I spoke to maxcdn, they could see it wasn’t pulling on their end.

    This is fixed in the next release.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Error: Empty hostname for MaxCDN Test’ is closed to new replies.