W3 Total Cache
Error: Empty hostname / CNAME list (19 posts)

  1. dzulfriday
    Posted 2 years ago #

    I am using rackspace cloud files, i setup 2 websites. The first website is just fine. The second one, it has been a few days, when i test Cloud files upload it will show:

    Error: Empty hostname / CNAME list.

    Both websites are using the same CHICAGO node, why is this happening?

    The weird is, i try upload the themes files is ok, shows green.


  2. cwalton
    Posted 2 years ago #

    Me too.

  3. AlexJS
    Posted 2 years ago #

    Same here using EU node

    "Error: Empty hostname / CNAME list."

    Triggered here:

    wp-w3-total-cache / lib / W3 / Cdn / Base.php

    * Test domains
    * @param string $error
    * @return boolean
    function _test_domains(&$error) {
    $domains = $this->get_domains();

    if (!count($domains)) {
    $error = 'Empty hostname / CNAME list.';

    return false;


    Not sure why as I provide the bucket.s3.amazon link ...


  4. head4space
    Posted 2 years ago #

    I get the same error when I try to set up W3 Total Cache for Rackspace CDN. I've tried creating the container myself or letting the plugin create the container. Both have the same result.

    The files upload (when you press the buttons to send them to the CDN) but when I enable the CDN it cannot see these files and so the site has no CSS, JS, Images etc.

  5. geophray
    Posted 2 years ago #

    I've got the same problem with an Amazon S3/Cloudfront setup. It seems to upload the files to S3 fine, and they are available via cloudfront if I try to pull up an image directly, but on the back end it keeps giving me that error. It's weird because the files are being served from cloudfront when my site loads, but when I run a test through webpagetest.org or yslow, it shows that none of my files are being loaded through the CDN. (I know they are loading in my browser because some of the files are missing from my local server, but they still load with the rest of the website.)

  6. head4space
    Posted 2 years ago #

    I've since found that if I let the plugin create the container (and not create it myself) and let it create the link that the error message is still present but it works.

    I've pressed all the upload buttons and now have around 150Mb of data being served from the rackspace CDN.

    After making the change make sure to purge the Page Cache, otherwise your local cache might give you mixed results.

    If you have a look at my page http://www.head4space.com and look at the URL for any of the images you will see that they are now being server by the CDN.

  7. debenedictis
    Posted 2 years ago #

    There is another thread on this topic that describes an edit you can make to lib/W3/AdminActions/CdnActionsAdmin.php to fix this:

    V 0.9.3 CDN Cloudfront Error - Empty Access Key

    It worked for me.

  8. geophray
    Posted 2 years ago #

    Thanks for the tip @debenedictis. Unfortunately that solution didn't resolve the problem for me, although it looks like it did for a couple of other people with a similar problem.

  9. scotthenning
    Posted 2 years ago #

    @geophray Having same issue here with RackSpace and above issue does not work.

  10. itagility
    Posted 2 years ago #

    I have the same problem on Amazon S3/Cloudfront. I can't get rid of the error

  11. Omega Supreme
    Posted 2 years ago #

    Not sure if this is allowed (anyone can correct me or flag this as such), but I disabled cdn in w3tc and temporarily installed CDN Linker as suggested by maxcdn. There's a lite version within the WordPress.org and a full version through github. Both are free.



    Depending on your cdn setup, if you have 4 dns entries, then you would add %4% to you cdn listing as such;


    Works perfectly and the best option since the cdn option is still broken. I tried the suggested edit/hack, but it didn't work for me either. Once w3tc is fixed, then can I go back to one plugin for everything...although in life, anything all-in-one tends to be problematic.

  12. elida
    Posted 2 years ago #

    I have the same problem.
    I changed my rachspac API and then entered the new on in w3tc and now I am getting this error.

  13. Vince Vega
    Posted 2 years ago #

    When I test Rackspace Cloud Files, I also get the error:

    Error: Empty hostname / CNAME list.

    I'm seeing the following in the log:

    PHP Warning: array_merge(): Argument #1 is not an array in /var/www/dev.mysite.com/wp-content/plugins/w3-total-cache/lib/W3/AdminActions/CdnActionsAdmin.php on line 377

    The function that's failing is action_cdn_test(), somehow it's not getting the CNAME that is entered in the CDN config.

    We started seeing transfer queue errors today, so things are feeling very wobbly. We're considering a downgrade to a prior version of W3TC...here's a link to the if anyone's interested: http://downloads.wordpress.org/plugin/w3-total-cache.

    Any word on a fix for this?

  14. Omega Supreme
    Posted 2 years ago #


    Disable CDN in W3TC and use CDN Linker (https://github.com/wmark/CDN-Linker) until the issue is resolved. It's easier than removing and downgrading W3TC....and it works.

  15. jmarx75
    Posted 2 years ago #

    In using rackspace cloudfiles, the plugin actually does work in that it uploads the file to my container. It's just the TEST button that is not working for me. I'm actually working on writing a patch for that, but just so you guys know you should be able you should be able to effectively use the plugin with rackspace cloudfiles(I haven't tested the others).

  16. Gavin Smith
    Posted 1 year ago #

    I had the same issue with WordPress 3.6.1 and version 0.9.3 of the W3 Total Cache plugin.

    Rolling back to version appears to have resolved this issue for me.

  17. MikeHenderson
    Posted 1 year ago #

    Error: Empty hostname / CNAME list.

    My CDN is Amazon S3 in the CDN configuration it shows the AWS hostname. What is wrong with this plugin or me?? Very weird.

    It doesn't seem that anyone has found a solution.

  18. geophray
    Posted 1 year ago #

    Hi Mike,

    Are you using S3 as the origin for your files for any particular reason? I had been but when this problem arose, I started using the generic mirror to have Amazon Cloudfront (Which incidentally is the real CDN... S3 is not a CDN. It is just storage.) pull the files directly from my server instance taking S3 out of the picture.

    If that is an option for you, I would recommend trying to configure it that way so you don't have to deal with the S3 issue.

    Here is a link to a tutorial that should help walk you through that process: https://rtcamp.com/tutorials/cdn/amazon-cloudfront-wordpress-w3-total-cache/

    Hope that helps!

  19. Brendan
    Posted 1 year ago #

    Hi all,

    I stumbled across this thread with the same problem but found no resolution. I was getting the "Argument #1 is not an array in" error when uploading to the CDN. I later found the source of my problem and have come back to share.

    The nail in the coffin was increasing the HTTP Timeout in Apache from 10 seconds back to the default 300 seconds. With my "Australian internet connection" it was the perfect storm to create this problem.

    I also found that my PHP max_execution_time and max_input_time were very low. I've now increased each setting to 90 seconds.

    I hope someone else finds this helpful.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic