WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache » Error: Empty hostname / CNAME list

Error: Empty hostname / CNAME list

  • I am using rackspace cloud files, i setup 2 websites. The first website is just fine. The second one, it has been a few days, when i test Cloud files upload it will show:

    Error: Empty hostname / CNAME list.

    Both websites are using the same CHICAGO node, why is this happening?

    The weird is, i try upload the themes files is ok, shows green.

    http://wordpress.org/plugins/w3-total-cache/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Me too.

    Same here using EU node

    “Error: Empty hostname / CNAME list.”

    Triggered here:

    wp-w3-total-cache / lib / W3 / Cdn / Base.php

    /**
    * Test domains
    *
    * @param string $error
    * @return boolean
    */
    function _test_domains(&$error) {
    $domains = $this->get_domains();

    if (!count($domains)) {
    $error = ‘Empty hostname / CNAME list.’;

    return false;

    }

    Not sure why as I provide the bucket.s3.amazon link …

    Anybody?

    I get the same error when I try to set up W3 Total Cache for Rackspace CDN. I’ve tried creating the container myself or letting the plugin create the container. Both have the same result.

    The files upload (when you press the buttons to send them to the CDN) but when I enable the CDN it cannot see these files and so the site has no CSS, JS, Images etc.

    I’ve got the same problem with an Amazon S3/Cloudfront setup. It seems to upload the files to S3 fine, and they are available via cloudfront if I try to pull up an image directly, but on the back end it keeps giving me that error. It’s weird because the files are being served from cloudfront when my site loads, but when I run a test through webpagetest.org or yslow, it shows that none of my files are being loaded through the CDN. (I know they are loading in my browser because some of the files are missing from my local server, but they still load with the rest of the website.)

    I’ve since found that if I let the plugin create the container (and not create it myself) and let it create the link that the error message is still present but it works.

    I’ve pressed all the upload buttons and now have around 150Mb of data being served from the rackspace CDN.

    After making the change make sure to purge the Page Cache, otherwise your local cache might give you mixed results.

    If you have a look at my page http://www.head4space.com and look at the URL for any of the images you will see that they are now being server by the CDN.

    There is another thread on this topic that describes an edit you can make to lib/W3/AdminActions/CdnActionsAdmin.php to fix this:

    V 0.9.3 CDN Cloudfront Error – Empty Access Key

    It worked for me.

    Thanks for the tip @debenedictis. Unfortunately that solution didn’t resolve the problem for me, although it looks like it did for a couple of other people with a similar problem.

    @geophray Having same issue here with RackSpace and above issue does not work.

    I have the same problem on Amazon S3/Cloudfront. I can’t get rid of the error

    Not sure if this is allowed (anyone can correct me or flag this as such), but I disabled cdn in w3tc and temporarily installed CDN Linker as suggested by maxcdn. There’s a lite version within the WordPress.org and a full version through github. Both are free.

    http://wordpress.org/plugins/ossdl-cdn-off-linker/

    https://github.com/wmark/CDN-Linker

    Depending on your cdn setup, if you have 4 dns entries, then you would add %4% to you cdn listing as such;

    http[:]//cdn%4%.domain-name(dot)com

    Works perfectly and the best option since the cdn option is still broken. I tried the suggested edit/hack, but it didn’t work for me either. Once w3tc is fixed, then can I go back to one plugin for everything…although in life, anything all-in-one tends to be problematic.

    I have the same problem.
    I changed my rachspac API and then entered the new on in w3tc and now I am getting this error.

    When I test Rackspace Cloud Files, I also get the error:

    Error: Empty hostname / CNAME list.

    I’m seeing the following in the log:

    PHP Warning: array_merge(): Argument #1 is not an array in /var/www/dev.mysite.com/wp-content/plugins/w3-total-cache/lib/W3/AdminActions/CdnActionsAdmin.php on line 377

    The function that’s failing is action_cdn_test(), somehow it’s not getting the CNAME that is entered in the CDN config.

    We started seeing transfer queue errors today, so things are feeling very wobbly. We’re considering a downgrade to a prior version of W3TC…here’s a link to the 0.9.2.11 if anyone’s interested: http://downloads.wordpress.org/plugin/w3-total-cache.0.9.2.11.zip

    Any word on a fix for this?

    @vince,

    Disable CDN in W3TC and use CDN Linker (https://github.com/wmark/CDN-Linker) until the issue is resolved. It’s easier than removing and downgrading W3TC….and it works.

    In using rackspace cloudfiles, the plugin actually does work in that it uploads the file to my container. It’s just the TEST button that is not working for me. I’m actually working on writing a patch for that, but just so you guys know you should be able you should be able to effectively use the plugin with rackspace cloudfiles(I haven’t tested the others).

    Gavin Smith

    @gavinsmithleapcomau

    I had the same issue with WordPress 3.6.1 and version 0.9.3 of the W3 Total Cache plugin.

    Rolling back to version 0.9.2.11 appears to have resolved this issue for me.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Error: Empty hostname / CNAME list’ is closed to new replies.
Skip to toolbar