Support » Plugin: Search Everything » error emails when posting new post

  • mttindustries

    (@mttindustries-1)


    I’ve been getting wordpress “something went wrong” emails every time I post a new post. The post posts fine but in the error messages it links it to this plugin

    Error Details
    =============
    An error of type E_ERROR was caused in line 927 of the file /home/slotmein/public_html/wp-content/plugins/search-everything/search-everything.php. Error message: Uncaught Error: Cannot use object of type WP_Error as array in /home/slotmein/public_html/wp-content/plugins/search-everything/search-everything.php:927
    Stack trace:
    #0 /home/slotmein/public_html/wp-includes/class-wp-hook.php(290): se_post_publish_ping(8068)
    #1 /home/slotmein/public_html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array)
    #2 /home/slotmein/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #3 /home/slotmein/public_html/wp-includes/post.php(4653): do_action(‘publish_post’, 8068, Object(WP_Post))
    #4 /home/slotmein/public_html/wp-includes/post.php(4021): wp_transition_post_status(‘publish’, ‘publish’, Object(WP_Post))
    #5 /home/slotmein/public_html/wp-includes/post.php(4197): wp_insert_post(Array, false)
    #6 /home/slotmein/public_html/wp-admin/includes/post.php(407): wp_update_post(Array)
    #7 /home/slotmein/public_html/wp-admin/post.php(219): edit_post()
    #8 {main}
    thrown

Viewing 3 replies - 1 through 3 (of 3 total)
  • Same error here. With no update to this plugin in 3 years I think it’s up to us/users to solve this. I’ll look as time permits but I hope someone else will do it sooner. šŸ˜‰

    It looks like the issue is that the Zemanta API no longer exists. I commented out everything below line 180 in search-everything.php and I no longer receive the error and the non-API functions appear to work just fine. šŸ™‚

    Thread Starter mttindustries

    (@mttindustries-1)

    considering that this plugin hasn’t had support and updates for 3 years, probably best to no longer use this. It’s a huge security risk just having it installed

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘error emails when posting new post’ is closed to new replies.