Support » Plugin: Veeqo for WooCommerce » Error during integration

  • Resolved goshunk358

    (@goshunk358)


    I have added my bridge URL as requested but it is just saying “an error occurred” then the following message:

    Installing from source: [bridge url here]
    Opening file for writing..
    Error downloading bridge file (HTTP code: 0). Please try again later.

    Could you help me fix this?

    Thanks πŸ™‚

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author calvify

    (@calvify)

    Hey @goshunk358!

    Quite often the issue when it fails to download completely is a case of the web server you’re running WordPress on not being permitted to make outbound requests to our domain (app.veeqo.com) and port 443. Can you confirm that your firewall is set up to allow such requests?

    If that all seems to be running ok and you’ve confirmed that it allows such access, then please drop our support team an email on helpme@veeqo.com. They’ll be able to help troubleshoot a bit more.

    Or if you don’t wish to open outbound access then there’s also the option of installing the bridge via FTP. This plugin just automates the whole process for you πŸ™‚

    Hope this helps!

    Calvin

    Thread Starter goshunk358

    (@goshunk358)

    Hi,

    Thanks for responding so quickly.

    I’ve followed the read me and uploaded the file & checked that I have set up the correct permissions.
    Now when I try to access the bridge file to test it I get:
    [M1_Pdo] MySQL Query Error: Can not connect to DB

    This is on wordpress hosting if that helps?

    Thanks πŸ™‚

    Plugin Author calvify

    (@calvify)

    Hi @goshunk358,

    It looks like it’s failing to parse the correct credentials from the config file in wp-config.php.

    Is it wordpress.com hosting you’re with? If so, do you have access to the wp-config.php file or is that restricted?

    Thanks,
    Calvin

    Thread Starter goshunk358

    (@goshunk358)

    I can access the wp-config file πŸ™‚

    it is wordpress.com hosting.

    Plugin Author calvify

    (@calvify)

    Hey @goshunk358,

    Great, so we’ll be able to debug that a bit better with you.

    I have a feeling the correct database credentials are not being loaded from the environment, so it’s failing to connect from there. Either that or it’s loaded them and the db is blocking the connection.

    Is it possible for you to drop an email to helpme@veeqo.com with just a basic bit of information on the problem you’ve described above and your store URL? Feel free to post the link to this thread too but I’ll give them a heads up regarding the issue πŸ™‚

    Thanks,
    Calvin

    • This reply was modified 1 year, 1 month ago by calvify.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error during integration’ is closed to new replies.