WordPress.org

Forums

WP Statistics
[resolved] Error Downloading GeoIP database (7 posts)

  1. Jargonsp
    Member
    Posted 10 months ago #

    I have set up the plugin and although everything works fine I can't seem to be able to download the GeoIP database from the settings page.

    I managed to download the correct database and placed it in the recommended folder but still no country information.

    Note: The site is still in development and I am just testing plugin compatibility so the only visits come from me through the dashboard and using some other PCs but all on the same connection.

    Any feedback would be appreciated.

    https://wordpress.org/plugins/wp-statistics/

  2. Greg Ross
    Member
    Plugin Author

    Posted 10 months ago #

    From the FAQ:

    = All visitors are being set to unknown for their location? =
    Make sure you've downloaded the GeoIP database and the GeoIP code is enabled.

    Also, if your running an internal test site with non-routable IP addresses (like 192.168.x.x or 172.28.x.x or 10.x.x.x), these addresses will come up as unknown always.

  3. Jargonsp
    Member
    Posted 10 months ago #

    Well the problem is that there is no way to download the GeoIP database from within the Dashboard since I always get this error:

    Error downloading GeoIP database from: http://geolite.maxmind.com/download/geoip/database/GeoLite2-Country.mmdb.gz

    if I open the location in my web browser I get this:

    403 Forbidden
    Rate limited exceeded, please try again in 24 hours.

    I have however managed to download the correct file through maxmind's site and tried placing it in my wordpress installation through ftp but still not working. What is the exact path I need to place it on the server?

    Thank you in advance.

  4. Greg Ross
    Member
    Plugin Author

    Posted 10 months ago #

    In your wordpress upload directory create a wp-statistics directory and place the extracted database in there.

  5. Greg Ross
    Member
    Plugin Author

    Posted 9 months ago #

    Closing due to inactivity.

  6. JohanPirlouit
    Member
    Posted 8 months ago #

    Hi Greg,

    I also have this problem but:
    - On my dev site: I can download the database from my personal dev server with NO problem.
    - On my production site: I can NOT download the database from my web hosting provider always with the same error:

    Error downloading GeoIP database from: http://geolite.maxmind.com/download/geoip/database/GeoLite2-Country.mmdb.gz - Forbidden

    By the way, I can download the compressed file with this URL, so the "Forbidden" is not related to the URL.

    Both versions of my website are hosted with nearly the same PHP settings:
    - PHP: 5.3.28 (5.3.10 on my personal dev server)
    - WP Statistics: 7.0.1
    - PHP Safe Mode: No
    - jQuery Version: 1.11.0
    - cURL Version: 7.21.0 (7.22.0 on my personal dev server)
    - BC Math: Installed

    When I manually upload the extracted database ("GeoLite2-Country.mmdb" file) in the "/wp-content/uploads/wp-statistics" folder of my production site, WP Statistics loads correctly the database...

    I tried to change "/wp-content/uploads/wp-statistics" permissions, with no success! Even with "777". This folder may not be the cause.

    It is a bit hard to debug because WP Statistics admin messages disappear too fast (less than half a second!). And I'm not sure to fully reset WP Statistics settings by disabling / uninstall / reinstall the extension...

    So I'm affraid I've got a permission problem with the temp folder that WP Statistics uses to download the GeoLite2-Country.mmdb.gz archive file. What is this temp folder?

    Regards,
    Johan

  7. Greg Ross
    Member
    Plugin Author

    Posted 8 months ago #

    Hi Johan, please create a new thread instead of reviving an old one.

    The message above is actually the maxmind site blocking your host IP address from downloading the database. You can contact maxmind to get your ip unblocked.

    WP Statistics uses the WordPress download function and it uses the WordPress temporary directory.

    If your on the settings page when you see the messages, try looking on the about tab, you may find the admin messages there (should be fixed in the next release).

Reply

You must log in to post.

About this Plugin

  • WP Statistics
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.