Error displayed during automatic plugin upgrade (5 posts)

  1. Scott Bressler
    Posted 5 years ago #

    I've seen similar errors to mine around the forum and Internet, but no solution to my particular problem: When I upgrade plugins using the admin interface, I get this error (some details changed for privacy):
    Warning: Cannot modify header information - headers already sent by (output started at /nfs/c05/h03/mnt/707XX/domains/mydomain.com/html/wp-admin/admin-header.php:18) in /nfs/c05/h03/mnt/707XX/domains/mydomain.com/html/wp-includes/pluggable.php on line 868

    Most people have said that there is an end php tag missing in some file, but the two files referenced are core files that I haven't modified. This happens after deactivating the old plugin and before removing the old plugin. Any ideas?

  2. esmi
    Forum Moderator
    Posted 5 years ago #

  3. Scott Bressler
    Posted 5 years ago #

    Thanks, esmi. As I said in my original message, however, I had tried doing what other people suggested, as on that page, with this error, albeit to no avail.

    Just to check, I downloaded a fresh copy of WP MU and diff'ed admin-header.php with the currently installed copy and there were no changes. Line 17, as you can see here, is where HTML output starts from that page (intentionally!) - this is not a simple PHP-end-closing-mark missing. Or if it is, it's not from admin-header.php. Any other thoughts?

  4. masonjames
    Posted 5 years ago #

    Any update on this? I have a wpmu 2.9.2 install that's throwing up the same error on automatic plugin upgrades (the upgrade does complete correctly though).

  5. TexInWien
    Posted 5 years ago #


    I have the problem on wpmu 2.9.2, as well. I have the exact same error as sbressler (directories are different, of course, but line numbers and files are the exact same) and the exact same behavior as masonjames.

    Would be nice to find a solution.

Topic Closed

This topic has been closed to new replies.

About this Topic