Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Error Details: Unable to insert blog.

  • Resolved geckoroutes

    (@geckoroutes)


    Since a few days, I cannot connect to my WP site anymore.

    Already removed Jetpack and installed it again but no change. Also didn’t it help to de-activate all plug-ins when re-installing jetpack.

    This is the error I get every time when Im trying to set up jet pack again:

    Error Details: Unable to insert blog. Please try again or contact support.

    And strange enough does the de-bugger also give an error (https://jetpack.com/support/debug/)

    An unknown error has occurred.

    Hope someone can help as the support is not available when you only have the free plan (Support for customers on Jetpack’s Free Plan is temporarily closed.)

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 26 total)
  • I am having this exact same issue

    Me 3

    I changed the site to https://www.

    @abarba your suggestion worked. I added www, activated Jetpack, removed www, deactivated Jetpack then reactivated it. Thank you!

    Thread Starter geckoroutes

    (@geckoroutes)

    Glad you found a solution!

    Could you please share how you did this exactly?

    Where did you add http://www.?

    I’m always working from https://www.

    But each time I try to connect, I get the same error.

    This is the link I used to re-connect

    https://wordpress.com/jetpack/connect

    Hi
    You need to
    1) go to wp-admin settings> general
    2)WordPress Address (URL) and Site Address (URL) add www to both
    3)try to connect jetpack again
    4)when finished remove www again if you want

    For more helps

    • This reply was modified 2 years, 3 months ago by netkarigar.
    • This reply was modified 2 years, 3 months ago by netkarigar.
    Thread Starter geckoroutes

    (@geckoroutes)

    Thanks for the steps, but no success here.

    Tried to remove the www. as I already had this as the standard domain.

    De-activated, removed and reinstalled jetpack and tested with www. and without but still the same error.

    Plugin Support supernovia

    (@supernovia)

    @geckoroutes on your site it looks like the site URL and home URL may be incorrect. Can you verify what those are currently?

    Also, I noticed your xml-rpc does not respond as expected when I use these tests:
    https://jetpack.com/support/getting-started-with-jetpack/fixing-jetpack-connection-issues/#check-xmlrpc-php

    So please do check the site URL / home URL settings, and if those are correct, check in with your host to verify if they’re blocking access to xml-rpc.php.

    Thread Starter geckoroutes

    (@geckoroutes)

    WordPress Address (URL): https://www.geckoroutes.com

    Site Address (URL): https://www.geckoroutes.com

    The response I get when loaden the XMLrpc file is”: HTTP Response code: 403 – Forbidden

    I’m also using Cloudflare for CDN but I didn’t change anything recently.

    It’s also possible to delete this file and upload a new verison?

    • This reply was modified 2 years, 3 months ago by geckoroutes.
    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Ah yes, that is indeed the problem.

    We’re being blocked from accessing https://www.geckoroutes.com/xmlrpc.php which Jetpack requires to function.

    Unfortunately, blocking XML-RPC is not a great solution for fighting security risks. It’s akin to selling your car because you don’t want it to be stolen.

    Your site’s XML-RPC file is kind of like a communication gateway to your site. Jetpack, the WordPress Mobile Apps, and other plugins and services will use this file to communicate to your site. If this is blocked, you will have other issues pop-up down the road for the same reasons.

    If you are using any security plugins, please try connecting with those temporarily deactivated. If you don’t have any, or if that didn’t work, I would suggest contacting your hosting provider and asking them to unblock your site’s XML-RPC. The most popular hosting providers out there have managed to find other ways to protect their servers without having to hinder your site and your ability to use services with your WordPress.

    Thread Starter geckoroutes

    (@geckoroutes)

    I found the plug-in that caused it. Apparently it was Clearfy.

    Now I can at least access the file:
    https://www.geckoroutes.com/xmlrpc.php

    Message is: XML-RPC server accepts POST requests only.

    However, I still get the same error in Jetpack.

    Even after re-installing it.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    We’re still getting “HTTP/1.1 403 Forbidden” from that file on our end. Did you re-activate the plugin that was blocking it?

    Thread Starter geckoroutes

    (@geckoroutes)

    Sorry activated the plug-in again to try to disable it from within. Now the file can be accessed again, but the problem is still the same. Also the debugger still says: “An unknown error has occurred.”

    I have the same problem since today.
    “Unable to insert blog. Please try again or contact support.”
    I have changed the URLs to www and back disabled and enabled the plugin.
    Nothing works at the moment.
    What can i do?

    Regards,
    Joerg

    Plugin Support supernovia

    (@supernovia)

    @joerg2503, if the suggestions in this thread have not helped you, would you start a new thread and include a link to your site in it? Thanks in advance!

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Error Details: Unable to insert blog.’ is closed to new replies.