WordPress.org

Support

Support » Plugins and Hacks » Cool Video Gallery » [Resolved] Error CVG 1.8 …ffmpeg not found

[Resolved] Error CVG 1.8 …ffmpeg not found

  • Hi,
    I was very happy with the CVG plugin. I could add videos, manage galleries, but what confuses me is that in the server log I get a message
    [client xxx.xxx.xx.xxx] sh: /Applications/ffmpegX.app/Contents/Resources/ffmpeg: not found

    When I check the site greece.mytravelmedia.com I don’t see any errors.
    I am using CVG 1.8

    http://wordpress.org/extend/plugins/cool-video-gallery/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Praveen Rajan

    @praveen-rajan

    @ Stretl

    Change the path of FFMPEG library in plugin settings page.

    Change the path of FFMPEG library

    How do I find the correct path?

    Plugin Author Praveen Rajan

    @praveen-rajan

    @ Stretl

    You will need to contact your webserver hosting admin for this. Also check if FFMPEG is installed in your shared server.

    It seems that is is installed correctly because the overview shows
    FFMPEG : Installed

    The strange thng is that it works I can add Videos and they are shown, so I assumed that everything was correct. Only when I look into the logfile I see the error.

    I will contact the admin

    Hi, I get the same error. I was wondering if you could help me find the file and the line where this command is executed so that i can comment it. I dont have any issues i just need to comment that output.
    Thanks

    On linux (CentOS) I had to set the Gallery Settings FFMPEG libary path to /usr/bin/ffmpeg

    This will cause the ffmpegcommandExists function in the lib/core.php to dump copious amounts of output to the error_log file on the server, slowing down web pages and loading up the disk with a bunch of error lgo fluff.

    Running a valid license check and routing output to /dev/null allows the exec command to run without generating output but while still testing if the ffmpeg executable is available at the path specified:

    I recommend the plugin developer add the noted options to the ffmpegcommandExists function:

    /**
             * Function to check if ffmpeg is installed.
             *
             * @author Praveen Rajan
             */
            function ffmpegcommandExists() {
    
                    $options = get_option('cvg_settings');
    
                $command = escapeshellarg($options['cvg_ffmpegpath']) . ' -L >/dev/null 2>/dev/null 1>/dev/null';
                exec($command, $output, $return);
    
                    if ($return <= 1) {
                            return true;
                    }
    
                    return false;
            }

    It appears to keep everything intact while no longer showing the ill side effects of the warnings being dumped to the log file, which is a LOT of extra disk I/O for naught.

    http://www.charlestonsw.com/support/documentation/store-locator-plus/

    I got my problem solved. If anyone is having the same issue i recommend commenting the following line in core.php file line 1406

    function ffmpegcommandExists() {

    $options = get_option(‘cvg_settings’);

    $command = escapeshellarg($options[‘cvg_ffmpegpath’]);
    —–> // exec($command, $output, $return);

    if ($return <= 1) {
    return true;
    }

    if you do this than ffmpeg wont be checked thus not giving any error

    Hello,
    I can not see the videos, the plugin allows me to install, but can not see them, they no longer appear either on my old pages, so I did not touch anything
    Can you help me?
    Thank you in advance
    Best Regards

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Error CVG 1.8 …ffmpeg not found’ is closed to new replies.
Skip to toolbar