WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Docs
[resolved] error creating a doc front end in a group (20 posts)

  1. Aaron Courtyard
    Member
    Posted 1 year ago #

    i have wp3.8 and bp 1.9.1. Should i roll back to 1.9?

    https://wordpress.org/plugins/buddypress-docs/

  2. Aaron Courtyard
    Member
    Posted 1 year ago #

    i rolled it back to 1.9 and still cant create a doc in a group. "There was an error when creating the doc."

  3. Boone Gorges
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not able to reproduce this problem.

    Can you (or anyone else experiencing the problem) please give additional details on your setup?

    - Docs version
    - What theme are you using
    - Other BuddyPress plugins
    - The user type you are logged in with (admin, non-admin)
    - BP configuration: are Activity and Groups both active?

  4. jamesnor
    Member
    Posted 1 year ago #

    Hi, I'm having a similar problem, a user cam upload a doc, but cant assign it to the two groups she is part of, when she goes to select the group from the dropdown, it displays "None".
    Thanks!
    Docs V: 1.5.6
    Theme: Salutation
    user type: Editor (Is fine for me - Admin - howeverwhen I update her to admin, I can then only see the groups she is not a member of)
    Activity and Groups are both active

  5. Boone Gorges
    Member
    Plugin Author

    Posted 1 year ago #

    jamesnor - Thanks. It sounds like this is a separate issue.

    So, just to be clear: you (Admin) can see your groups in the My Groups dropdown, but non-Admins cannot see their groups?

    > howeverwhen I update her to admin, I can then only see the groups she is not a member of

    Can you say more about this? I'm afraid I don't understand.

  6. Aaron Courtyard
    Member
    Posted 1 year ago #

    - Docs version newest
    - theme is a rockettheme
    - Other BuddyPress plugins:
    BP Activity Autoloader
    Bp Force Profile
    BuddyPress Activity Plus
    BuddyPress Activity Privacy
    Buddypress Notifications Manager
    BuddyPress Notifications Widget
    Buddypress Social
    BuddyPress Wall
    BadgeOS
    BadgeOS Community Add-On
    RS Buddypress Activity Refresh
    rtMedia for WordPress, BuddyPress and bbPress
    - The user type you are logged in with (admin)
    - BP configuration: are Activity and Groups both active? Yes they are

  7. Aaron Courtyard
    Member
    Posted 1 year ago #

    i love this plugin and am able to use it by creating doc in admin panel and reassigning it to a group on the front end. Its a work around for now.

  8. julala
    Member
    Posted 1 year ago #

    I have the same problem - using the same workaround as Aaron. Means only admin can create new docs though.

  9. Boone Gorges
    Member
    Plugin Author

    Posted 1 year ago #

    Can anybody give more details about what the error actually is? I've reread the thread above, but I don't have enough information to reproduce. If anyone could list the *exact steps* that I would need to take to reproduce on my own installations, it'd be helpful.

  10. Aaron Courtyard
    Member
    Posted 1 year ago #

    After clicking Create a new doc, filling out the doc. "There was an error when creating the doc."

    http://youringenuity.com/new/wp-content/uploads/2014/01/docs-support-pic1.jpg

  11. Boone Gorges
    Member
    Plugin Author

    Posted 1 year ago #

    Aaron - Thanks. Is it possible for you to test with a standard WP theme (such as Twenty Twelve) to see if the problem is linked to your theme?

  12. julala
    Member
    Posted 1 year ago #

    I am using a TwentyTwelve child theme with minimal alterations having -with the same issue. (same child theme on a different site does NOT have the same problem) so I am guessing it is a plugin clash.

    Plugins installed:

    Akismet
    bbPress
    BuddyPress
    BuddyPress Docs
    BuddyPress Group Email Subscription
    BulletProof Security
    CiviCRM
    CiviMember Role Synchronize
    Custom sidebars
    Drop Shadow Boxes
    Exclude Pages from Navigation
    Jetpack by WordPress.com
    Piklist
    Q and A FAQ and Knowledge Base for WordPress
    Remove Dashboard Access
    Role Scoper
    SI CAPTCHA Anti-Spam
    Simple Local Avatars
    Theme My Login
    ThreeWP Activity Monitor
    UK Cookie Consent
    User Role Editor
    Visual Form Builder
    W3 Total Cache
    WordPress Helpers
    WordPress SEO
    Wysija Newsletters

    When I go to create new Doc from frontend the text box is not visible, attachments button does not work and new doc will not save at all.

    My error is the same as Aaran's but you will also see no visual text editor loading either.

    http://s28.postimg.org/6osxxg38t/bbdocs_FAIL2.png

  13. Aaron Courtyard
    Member
    Posted 1 year ago #

    yes, will post results soon

  14. Boone Gorges
    Member
    Plugin Author

    Posted 1 year ago #

    julala - Thanks for the details. The bit about the visual text editor may be a helpful hint. It suggests that there might be a javascript problem. Do you know how to use your browser's JS console? Here are details for various browsers: https://www.google.com/search?q=open+javascript+console&oq=open+javascript+console&aqs=chrome..69i57j0l3.4146j0j1&sourceid=chrome&ie=UTF-8

    Open up a console and watch for errors when you try to do this posting.

  15. julala
    Member
    Posted 1 year ago #

    thanks...but the text editor works on other areas of the same website....and perfectly ok on my other site using the same plugin.

  16. Boone Gorges
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, but clearly something is going wrong when you attempt to post a Doc. Can you please check to see whether the javascript console shows any errors when you attempt to do this?

  17. julala
    Member
    Posted 1 year ago #

    This means little to me....but maybe helpful to you:

    jconsole stuff

  18. Aaron Courtyard
    Member
    Posted 1 year ago #

    So i deactivated my theme and it works. I wasn't prepared to have to put all the widgets back into place. So its the theme.... now what? Is it something i can fix?

  19. Boone Gorges
    Member
    Plugin Author

    Posted 1 year ago #

    julala - Thanks. I'm going to dig more into it, but it looks like something in one of your plugins is preventing certain JS libraries from loading. It's hard to guess which one this might be; if you have the ability to do so, it'd be great if you could experiment by toggling them on and off.

    Aaron - It's a bit hard for me to debug a theme I don't have. Maybe you could contact the person you bought the theme from?

  20. Aaron Courtyard
    Member
    Posted 1 year ago #

    its funny, i bought it from Rocket theme on the gantry framework, I like the theme but the way they deliver support is based on how much you pay and there is a time limit, and they seem to milk that time limit so you have to pay again. Right now i have ran out of support time with none of my support issues dealt with.

    it causes some wonder, do themes get updated? Should i not be updating plugins since it seems that the theme issue is coming up more and more?
    the theme is from 2011.

    in the long run its good that i have to dive deeper into these issues because i learn more and more. at the same time it feels like this is where WP is a little hokey. Thus all the support needed. Nothing is truly a turnkey.

    What i fear is that i will some day have to make my own theme just to deal with these little issues that come up.

    I have no trouble marking this thread as resolved. Everyone washes there hands of it with good reason. and in the end i may have to do the same. Maybe of WP too. Who knows maybe it will get better.

    I really appreciate your time. You have been very attentive and i am grateful.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.