Support » Fixing WordPress » Error: could not find an RSS or ATOM feed at that URL.

  • Resolved mvveelen


    Hi there.

    This question has been asked a few times, but there has never been a solution for this. Maybe this time ?

    I have problems getting the RSS feed from other news-sites to work.

    I even installed 3 FRESH wordpress versions to test it, but I always get the same error message.
    A friend of mine, who is a member of the same host has it working on his site, so it can’t be a restriction on the host’s server.

    Another friend gave me the settings that work for him on his site, but they don’t work on my site.

    Who can finally help me to get the RSS widget to work on my website….

    Help ?

Viewing 13 replies - 1 through 13 (of 13 total)
  • For example, I’d like to add this :

    And again I get the message : “could not find an RSS or ATOM feed at that URL.”

    Getting pretty frustrated at the moment……..

    I can’t beleive there’s nobody who has an idea why this doesn’t work on some WordPress installations ……. ?

    If somebody has any idea ?

    Installed 2.6.5 and the 2.7RC1 in a new subdir : no result.

    Installed 2.6.5 on another webserver with exactly the same settings and rss-feed : working !

    So it must be something on the host’s server, but what ? And evenmore : a friend of mine has the same host and on his website the rss-feed DOES work (maybe he has another server with different settings ?).

    What can be the problem on the server causing this problem for me (and several others) you guys think ?

    Solved !!

    I had to use some kind of include-url because the host has blocked this kind of includes on the server I’m on.

    Can you clarify this include-url? I’m having the same problem on my own site.

    Well, in my case it is something like :

    You can ask your own host what it should be like on your server

    Color me clueless here, but after my own upgrade to 2.7, I have the same issue. The feeds I’ve had won’t update, and once removed and then restored, I get the error message you see above.

    I’d ask the guy who runs the server, but unfortunately, that’s me.

    No other changes between the update and when the RSS feeds stopped working in my sidebar widgets.

    I get the same error when I upgraded from 2.6 to 2.7. None of the RSS feeds in the Dashboard update/display.
    Any ideas?

    Each of you might want to ask in separate threads since this one has been marked as resolved by the original poster and as such not many people will look at it since they think the problem has been fixed..

    You might reference this thread in yours..

    Anyway, my 2 cents…

    Thanks mvveelen! I checked with my hosting company, webhost4life, and they’re trying to resolve for me. Not sure it’ll work, but at least there’s a glimmer of a solution.

    OK, it worked! In a strange, roundabout way. I didn’t hear back from my hosting co, but what I did was use the include URL from mvveeleen with my feed address and saved it. Which saved finally with the correct name. Then I edited out his include URL and now it works fine.

    If that doesn’t work, instead of clicking “done” and then “save changes” – just click “save changes” when you’re done editing.

    This solution worked for me when I was getting the same error. It can be found on this thread:

    The instructions I followed were:

    1. Download the latest magpieRSS package from here:

    There’s a lot of files in this tarred and gzipped archive. You only need the four .inc files in the root directory.

    2. Dump,, and into the wp-includes directory.

    3. Near the beginning of, change the call to to this:

    require_once( MAGPIE_DIR . ‘class-snoopy.php’);

    This will work as class-snoopy.php is already in the wp-includes directory and there’s no need to install the extlib directory.

    4. Rename to rss.php and overwrite existing rss.php file in wp-includes with the new file.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Error: could not find an RSS or ATOM feed at that URL.’ is closed to new replies.