Support » Fixing WordPress » ERROR: Cookies are blocked or not supported by your browser. You must enable coo

  • I can’t log into my blogTrust Me as of about 1/2 hour ago. Up until then everything was fine. I checked my wp-login.php

    // If the user was redirected to a secure login form from a non-secure admin page, and secure login is required but secure admin is not, then don't use a secure
    	// cookie and redirect back to the referring non-secure admin page. This allows logins to always be POSTed over SSL while allowing the user to choose visiting
    	// the admin via http or https.
    	if ( !$secure_cookie && is_ssl() && force_ssl_login() && !force_ssl_admin() && ( 0 !== strpos($redirect_to, 'https') ) && ( 0 === strpos($redirect_to, 'http') ) )
    		$secure_cookie = false;
    
    	// If cookies are disabled we can't log in even with a valid user+pass
    	if ( isset($_POST['testcookie']) && empty($_COOKIE[TEST_COOKIE]) )
    		$user = new WP_Error('test_cookie', __("<strong>ERROR</strong>: Cookies are blocked or not supported by your browser. You must <a href='http://www.google.com/cookies.html'>enable cookies</a> to use WordPress."));
    	else
    		$user = wp_signon('', $secure_cookie);

    [Moderator Note: Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum’s parser.]

    It’s not my server as I can log into my other WordPress blog, which is the same wp version (3.8.1)

    Sublime Ramblings

    The only thing I did was edit ‘functions.php’ to add favicon.ico but it didn’t work, so I deleted that portion.

    I also cleared the wp-content cache, thinking this would help, but it did not.

    Any help at all is appreciated.

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘ERROR: Cookies are blocked or not supported by your browser. You must enable coo’ is closed to new replies.