[resolved] ERROR: Cookies are blocked or not supported by your browser. You must enable coo (15 posts)

  1. WPMonty
    Posted 2 years ago #

    Fresh install of 3.7.1 on localhost
    Cannot login.
    ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.

    Failed troubleshooting so far:
    Cookies enabled in browsers (FF, Chrome). failed.
    Disabled plugins (manually). failed.
    Cleared browser cache (FF, Chrome). failed.

    wp-config.php hack. failed.
    wp-login.php hack. failed.
    functions.php hack. failed.

    Troubleshooting above indicates WP core error. New WP 3.7.1 login cookie remains unset. Please help, I've exhausted all options.

  2. Tara
    Volunteer Moderator
    Posted 2 years ago #

    It's more like to be a server sessions or cookie issue. Have you spoken to your hosts about it? Or checked your error logs?

  3. WPMonty
    Posted 2 years ago #

    There is no host because it runs on local MAMP.

    PHP error logs pointed to an empty script-init.php file. Removing the file allowed everything to go back to normal for now.


  4. Tara
    Volunteer Moderator
    Posted 2 years ago #

    ok. Let'e know if any issue

  5. tanver
    Posted 2 years ago #

    Same here my friends, I have even reverted to v3.7 but am still unable to access the admin panel.

    I have read about it in another thread that this is an issue with v3.7.1

    Please do let us all know if you come across a way out of it.

  6. WPyogi
    Forum Moderator
    Posted 2 years ago #

    @tanver - this thread is resolved, so won't be a good place to get help with a new issue - and unless your site is on local host, not the same issue.

    Have you read through this?


    If you need additional help, please do start your own thread as per:


  7. TheArch
    Posted 2 years ago #

    This worked for me:

    • Renamed the Active theme before update.
    • Successfully logged in
    • Changed back to the original Theme

    For this freaking thing i had to spend two hours googling :-(

  8. Zain Ul abideen
    Posted 1 year ago #

    I have solved that one, Please rename or removed you plugins one by one , you just got that solved.

  9. idsugeng
    Posted 1 year ago #

    i'm using wp 3.8.1 and can't login to wp-admin plugin, the cause is plugin "Quick Featured Images". After i remove that plugin, i can login to wp-admin.


  10. conidis
    Posted 1 year ago #

    Same here

    Happened to me twice (3.8.1). I found the culprit, it was a plugin. If you only have a live-running installation and want to avoid crashing your website:

    • Do not delete cookies
    • Start renaming your plugins' folder names (NOT the "plugins" folder) one at a time starting from the less essential ones, if any.
    • Refresh login page
    • Try to login. If first attempt fails, try once more. On many occasions second try works.
    • If it still fails, rename plugin folder name to original name.
    • Go to next plugin. Repeat the steps

    Hope this works, did for me.

  11. Doctor Ngobeni
    Posted 1 year ago #

    I have the same issue, here's the website. I get the exact same error.

  12. Tara
    Volunteer Moderator
    Posted 1 year ago #

    @Doctor Ngobeni:

    This is a "resolved" thread.

    To get attention to your specific issue as you deserve, my suggestion is to start a new thread. Review this: http://codex.wordpress.org/Forum_Welcome#Where_To_Post

  13. colinibberson
    Posted 1 year ago #

    I've tried putting on a new post like this but ironically the instructions are for how to set up a question via WordPress and I can't login to WordPress!!

  14. ry4nallen
    Posted 1 year ago #

    Hey Guys,

    If none of these are working you may need to check with your hosting provider to ensure that Varnish isn't enabled.

    See thread: https://wordpress.org/support/topic/cookies-are-blocked-or-not-supported-since-update-to-371/page/3

    This was the case for a client site. Was a hard one to track down, for sure.

  15. barnez
    Posted 1 year ago #

    @ WPMonty
    Your link to the wp-config.php hack worked for me. Thanks for posting

Topic Closed

This topic has been closed to new replies.

About this Topic