Support » Fixing WordPress » ERROR: Cookies are blocked or not supported by your browser

Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator t-p

    (@t-p)

    Add below line to your wp-config.php before /* That’s all, stop editing!…*/

     define('COOKIE_DOMAIN', $_SERVER['HTTP_HOST'] );
    
    /* That's all, stop editing! Happy blogging. */

    If that does not help, find out if your server/web host is filtering out the cookies that WordPress uses to handle logins (Varnish…).

    Thanks I have done that. I have added everything I have found for the last 6 hours. Now I try to get a new password as another solution and I get the email link.
    “Your password reset link appears to be invalid. Please request a new link below.” I used to be able to access my Earthlink email and I noticed an error in the URL about cookie error. So I think WordPress cookies are blocked or filtered by the Network. my exact websites work ok on my local host.

    Also I didn’t make any changes to my site or files. It started yesterday. So this leads me to believe the Network is blocking or filtering cookies. But I need the info to share with Network people what is getting blocked.

    Moderator t-p

    (@t-p)

    Have you also tried:
    – deactivating ALL (yes all) plugins temporarily to see if this resolves the problem (plugin functions can interfere). If this works, re-activate them individually (one-by-one) to find the problematic plugin(s).
    – If you don’t have access to your Dashboard’s Plugins page, try manually resetting your plugins (no Dashboard access required). Here is another tutorial: http://www.wpbeginner.com/plugins/how-to-deactivate-all-plugins-when-not-able-to-access-wp-admin/ – If that resolves the issue, reactivate each one individually until you find the cause. Also remember to deactivate any plugins in the mu-plugins folder (if you have created such folder). The easiest way is to rename that folder to mu-plugins-old.
    – switching to the unedited default Theme (Twenty Seventeen, etc.) for a moment using the WP dashboard to rule out any theme-specific issue (theme functions can interfere like plugins). If you don’t have access to your Dashboard’s Appearance page, access your server via FTP/ SFTP , or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), navigate to /wp-content/themes/ and switch to the default theme by renaming your current theme’s folder by adding "-old" to the end of the folder name. Alternately, you can remove other themes except the default theme (Twenty Seventeen, etc.). That will force your site to use it.

    If the above trouble shooting steps do not help, then try Enabling debugging and post the results.

    Yes I have done all this. No errors in debugging. Again everything was working fine most of the day. No changes to any files, database or plugins.

    Moderator t-p

    (@t-p)

    Have you also checked the error logs on your server for a any specific error message and see why it’s failing. If you need help locating them, ask your hosting provider to help you with that.

    Why would I be able to log into the exact same site outside the network and have to errors?

    Moderator t-p

    (@t-p)

    If you can install plugins, please install the health check plugin and review the output for any clue, or post the output here (excluding any sensitive info).

    Got it fixed it was the network blocking the temporary cookies.

    I’m having the same problem, except that I can successfully log in on a second attempt. I installed and ran Health Check, and didn’t find anything major. My server is running PHP 7.0.30, and I don’t know if I can get that updated. I will have to talk to my hosting provider about that.
    I’ve got an issue with getting https working properly on my site as well, but I don’t think this is related. I have a Comodo certificate installed, but when I use one of the https plugins (in this case SSL Insecure Content Fixer), then I can’t see any images when I’m trying to edit posts. I’ve had similar issues with other SSL plugins.

    In trying to troubleshoot this problem I came on this in another thread:

    This is due to the fact that WordPress enforce a $secure_cookie control over an encrypted channel for admin logins. Reconfigure your web server to enforce SSL/TLS. KR. – user105503 Oct 23 ’16 at 12:30

    As it turns out if I manually change my login URI to HTTPS the problem is fixed. Well shit. There you go. Time to go and reconfigure my web server…

    • This reply was modified 1 year, 6 months ago by Doug Nix.

    I cannot log into my sites and now get this error. “ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress”.
    but this error is occur when i have installed wp total catch plugin.
    this error is gone when i have uninstall wp total catch plugin..but i want to use wp total catch plugin.how it’s possible?

    Moderator t-p

    (@t-p)

    Side note to @ktmcleopatra,

    It’s over 11 months since the OP posted. Also, if you noticed, this thread is marked “resolved”.

    Please do not jump into other topics. If the troubleshooting already posted made no difference for you, then, as per the Forum Welcome, please post your own topic.

    Your reply has been archived.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘ERROR: Cookies are blocked or not supported by your browser’ is closed to new replies.