• Resolved jrivett

    (@jrivett)


    When I publish a post, or even if I just go to edit a post or page, I see these warnings at the top of the screen:

    Error connecting to https://boot13.com/?p=17275 for caching (HTTP code 301). 
    Ignoring requests to cache this URL for 900 second(s).

    Error retrieving webpage from https://boot13.com/?p=17275.

    And yet editing and posting seem to work okay otherwise. Any idea what is causing these, and/or how to get rid of them?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author JS Morisset

    (@jsmoriss)

    There’s a problem with your server – perhaps a DNS issue or somekind of firewall filtering – you should contact your hosting provider to get this fixed.

    js.

    Thread Starter jrivett

    (@jrivett)

    The site works fine, as do the others hosted on that server. DNS also checks out. I disabled a couple of security plugins (BPS and Wordfence) but nothing changed. WPSSO seems to work okay, despite the messages. But I’d be happier if I knew what conditions are leading to the messages. Can you provide any background on what causes them to appear? For the record, the reported URLs actually work.

    Plugin Author JS Morisset

    (@jsmoriss)

    Your WordPress site (not your browser) is unable to connect to that URL. As suggested earlier, please contact your hosting provider to have the issue fixed.

    js.

    Thread Starter jrivett

    (@jrivett)

    It would really help if I knew what to tell them. From the perspective of your plugin, what is the significance of the messages? What is WPSSO trying to do that is causing it to show those messages?

    Plugin Author JS Morisset

    (@jsmoriss)

    The plugin retrieves the webpage to check for duplicate meta tags. The following errors should be sufficient for your hosting provider to understand the issue – they are probably already aware of it. 😉

    
    Error connecting to https://boot13.com/?p=17275 for caching (HTTP code 301). 
    Ignoring requests to cache this URL for 900 second(s).
    
    Error retrieving webpage from https://boot13.com/?p=17275.
    

    js.

    Thread Starter jrivett

    (@jrivett)

    Question from the hosting provider: when WPSSO tries to access the URL in question, what HTTP method and user-agent are used?

    Plugin Author JS Morisset

    (@jsmoriss)

    Method = See the URL in the error message. 😉 It’s the post / page permalink.

    User agent = “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0”

    The user agent can be changed using the WPSSO_PHP_CURL_USERAGENT constant.

    Obviously, since any browser, robot, crawler, spammer, etc. can send whatever user agent string they way, the user agent string is never used to manage / control access, so I’m not sure why they’re asking that. Generally, the user agent is sometimes used to modify webpage content for different browsers (ie. Internet Explorer vs all other browsers).

    js.

    Thread Starter jrivett

    (@jrivett)

    Regarding User Agent: thanks for that. At least one WordPress security plugin does indeed (by default) block based on User Agent: BPS.

    Regarding method: I believe they wanted to know if WPPSO is performing a GET request, or something else, perhaps a HEAD request.

    Meanwhile, I’ve run into a separate problem with WPSSO and I’ve had to disable it for now. I think WPSSO is a terrific plugin, and very much want to use it, but I’ll have to re-evaluate it again later. I’ll post the new issue in a separate thread.

    I had this issue going on for a month. ISP was lost and not able to help figure it out.
    Resolving to do it myself, I solved the issue. It had nothing to do with DNS, Caching, redirects, WordPress core or plugin functionality at all.

    Looking at the cPanel error log there were thousands on thousands of denied requests from hosting server xxx.xxx.xxx.xxx

    Also the Visitor log was full of thousands on thousands of 403 POST and GET errors from hosting server xxx.xxx.xxx.xxx

    This led me to believe there was a security block on the internal server side of things. Digging further I found the IP address xxx.xxx.xxx.xxx in the cPanel IP blocker list.
    As soon as I removed the IP from this list I suddenly was getting tons of e-mail from the WP site security plugin that alerts me to file checksum mismatches and I was able to check the original page / post editing in WordPress to see the WPSSO Note issue was resolved too.

    I get the same error.. My situation was that I have my site in Maintenance mode with “Coming Soon Page & Maintenance Mode by SeedProd” plugin.
    After I go with my site online again the “Error retrieving webpage from …” disappeared!

    This error was solved by my host disabling open_basedir on my account

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Error connecting / Error retrieving webpage’ is closed to new replies.