Support » Plugin: Asset CleanUp: Page Speed Booster » Error concerning Tiny MCE since update

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Gabe Livan

    (@gabelivan)

    @berndg17 Is this an issue loading in the front-end view? The Dashboard shouldn’t be affect. Also, do you have this problem when you edit a post/page or any post type? I haven’t had this error before. There could be a plugin incompatibility. Can you send me a few print screens? You can do it via a service such as https://imgbb.com/

    Thread Starter berndg17

    (@berndg17)

    Thanks for caring and this really great plugin. Since I deactivates “Combine loaded JS (JavaScript) into fewer files” the problem is gone. I will try to deactivate one plugin after the other these days and report. What kind of screenshots do you need?

    Yours, Bernd

    Plugin Author Gabe Livan

    (@gabelivan)

    @berndg17 this suggests that you’re having this error in the front-end view (outside the Dashboard), correct me if I’m wrong. A print screen of the page where you have this issue with the console open would be good. I’m sure the problem is easy to fix as there’s likely a JS file there that doesn’t need to be combined, but left to load independently.

    Thread Starter berndg17

    (@berndg17)

    Correct. It`s happening in WP Foro, a community-plugin. I’ll prepare a screenshot.

    Plugin Author Gabe Livan

    (@gabelivan)

    @berndg17 did you update WP Foro at around the same time you updated Asset CleanUp? They could have updated their JS files and one of them shouldn’t be combined. Another thing you can try is enable combine JS ONLY for you (the checkbox right under the radio button) and exclude /wp-includes/js/tinymce/langs/ from any combination. This could fix it.

    Thread Starter berndg17

    (@berndg17)

    Here we go … https://ibb.co/zG6Bs0b

    Plugin Author Gabe Livan

    (@gabelivan)

    @berndg17 It looks like the file /wp-includes/js/tinymce/langs/de.js doesn’t exist, but you do not get the error anymore once you deactivate combine JS. Can you check the console as well via right-click, “Inspect”. I’ve checked the WordPress directory and the only file there is /wp-includes/js/tinymce/langs/wp-langs-en.js. Something could alter the path to the de.js that is likely stored somewhere else when you activate combine JS. Is this editor showing up only to logged-in users?

    Thread Starter berndg17

    (@berndg17)

    Yes, it’s a membersite, this is in the paid section, only for logged in users.

    Checked it via ftp, true, the file is gone. Thanks for your analysis, this should be easy to change.

    Plugin Author Gabe Livan

    (@gabelivan)

    @berndg17 In this case, you should be fine leaving combine JS disabled. In terms of user experience, there’s really no difference, especially since you server supports HTTP/2 (you can make a quick test here: https://tools.keycdn.com/http2-test). In future version of the plugin, combine JS will be automatically disabled for logged-in users. It usually make sense to have combine CSS/JS turned ON if your web server doesn’t support HTTP/2 protocol &. you have lots of CSS/JS files that are loading. I definitely need to write a post in the documentation about advantages and disadvantages of combining CSS/JS files.

    Thread Starter berndg17

    (@berndg17)

    Update, problem finally solved: I loaded the german file from https://www.tiny.cloud/get-tiny/language-packages/ , copied it via ftp to /wp-includes/js/tinymce/langs/ and everything is fine.

    Thanks!

    Plugin Author Gabe Livan

    (@gabelivan)

    @berndg17 that’s great news! If you’re happy with the plugin overall, it would be awesome if you can spare a minute and leave a quick review about it here: https://wordpress.org/support/plugin/wp-asset-clean-up/reviews/#new-post

    Thread Starter berndg17

    (@berndg17)

    I did already weeks ago 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error concerning Tiny MCE since update’ is closed to new replies.