Support » Fixing WordPress » Error Code Help

  • This code below is on the Botton of my website. I can’t seem to figure out why it is there and how to get rid of it. Can anyone help me please?

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘sdc_social_menu’ not found or invalid function name in /home/artwork6/public_html/wp-includes/class-wp-hook.php on line 286

    Thank you!
    Let me know if more information is needed.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Harsh

    (@harshsoni_w3)

    Looks like one of your plugin is causing this issue. It is usually caused by a filter or an action not properly declared.
    Try to deactivate them one by one and check if it works.

    Moderator t-p

    (@t-p)

    Check if you have this line in your wp-config.php:
    define( ‘WP_DEBUG’, true );

    If you do, change it to:
    define( ‘WP_DEBUG’, false );

    Okay! Thank you! I’ll check both of your suggestions.

    @t-p I do have that line in there but it does in fact say false. Any other ideas?

    @harshsoni_w3 I’ll try your suggestion. Thank you.

    Moderator t-p

    (@t-p)

    What did you before the error occurred?

    Also, please check the error logs on your server for a more specific error message and see why it’s failing. If you need help locating them, ask your hosting provider to help you with that.

    This is what is on line 286 of class-wp-hook.php:

    $value = call_user_func_array( $the_[‘function’], $args );

    Does this look weird to anyone?

    @t-p I went to my error log and nothing is showing. There isn’t a single error…weird. I don’t know what could be happening if there aren’t any errors logged.

    This is what is on line 286 of class-wp-hook.php:

    $value = call_user_func_array( $the_[‘function’], $args );

    I don’t know if this helps

    • This reply was modified 2 years, 7 months ago by bearsauto.

    @harshsoni_w3

    Okay I found that it was a plugin. It was my Storefront Design Customizer plugin. I don’t know how to fix it though. I use this plugin for so much of my design that if I keep it off then my website looks wrong, but if I turn it back on then the error is there. Any tips?

    Moderator t-p

    (@t-p)

    I recommend asking at https://wordpress.org/support/plugin/storefront-design-customizer so the plugin’s developers and support community can help you with this.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error Code Help’ is closed to new replies.