Support » Plugin: Super Page Cache for Cloudflare » Error Code 7003 No Route for That URI

  • I get the following Error when I click on the “Enable Page Caching Now” button.

    “Could not route to /zones/settings/browser_cache_ttl, perhaps your object identifier is invalid? (err code: 7003 ) – No route for that URI (err code: 7000 )”

    Some assistance will be appreciated.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @kodeexii ,
    are you sure that all the data entered by you are correct? And if you are using the API Token, are you sure that your token has all the required permissions?

    It looks like a permissions problem.

    I am 100% sure my API credentials are right, and also facing this message.

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Please paste here the logs

    Sorry, I can’t paste my logs here; I’m an authorized user for some clients of mine, and the logs would expose data that do not belong to me.

    However, I think I have something new to share: the failed API call is:

    https://api.cloudflare.com/client/v4/accounts//workers/scripts

    Notice the double-slash in the URL; it is supposed to have an ID after “accounts” and before “workers”; for some reason the plugin can’t get this ID.

    I don’t know how to send a screenshot here, but you can see an excerpt of my log here (sensitive data redacted):

    https://shares.cdnfacil.com.br/2020/12/log_25840CCA.png

    None of the retrieved accounts is my own, all or of my clients’.

    I tried to generate an API token, but I failed to figure out the needed permissions. Perhaps I misread the docs, I’ll read it again.

    I created an API token, and now the message is:

    Authentication error (err code: 10000 )

    It’s a miss, I really like this plugin, but… 🙁

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Notice the double-slash in the URL; it is supposed to have an ID after “accounts” and before “workers”; for some reason the plugin can’t get this ID.

    Ok the problem is that you manage multiple accounts from the same Cloudflare interface.

    To solve this, on the General tab you must enter the Cloudflare e-mail associated with the CF account of your domain. Then disable and enable the cache.

    Let me know

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Authentication error (err code: 10000 )

    Are you sure that your API token has all the required permissions?

    It’s hard to help you without logs. The error code 10000 can be returned by many API calls, so I need to know what is the API from the logs.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Error Code 7003 No Route for That URI’ is closed to new replies.