• Resolved thugyecz

    (@thugyecz)


    Hi!

    After the last update, our longer pages that contain our Google Photos galleries do not load (sometimes, they just load forever, sometimes, there is an error code of 429, stating that we have exceeded our quota for requests), as you can see from the Google Photos API, there is a horrible 1500ms latency and a 99% error rate for the requests. I have no idea what causes this problem, other pages, that contain only max. 10-15 albums sometimes load, but sometimes not.
    http://prntscr.com/nawmhx
    Right now I am trying to roll back to the old version (I suppose v2.23) from the backup to check, if it was the update or not (before the update everything worked fine, and now I experience this thing 1 day after the update, so I believe this thing has to be related to the update, because I did not change or update anything else).
    I am using PHP 7.2, and there is nothing related to this in the PHP error log, I just checked.

    Am I the only one, or is anyone else experiencing this also? What could be the cause of the 99% error rate in those API method calls?

    Thanks,
    thugyecz

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • UPDATE: I reverted back to Photonic v2.23 and everything works fine, just as before the update. So the problem that I was experiencing is directly related to the v2.24 update in my case.

    Plugin Author Sayontan

    (@sayontan)

    There is as one change that might be affecting you. How many albums do you have in all? And what shortcode are you using to display them?

    The affected page contains most of the albums out of the 223 that is currently uploaded to Google Photos, as this is the main gallery page, so only a few albums are excluded. I am using Gutenberg’s Block Wizard to select the specific albums that I want to display. This results in a long shortcode full of album ID’s, starting with: “type: google, view: albums, filter:….”.

    Plugin Author Sayontan

    (@sayontan)

    OK, my hunch was correct. In 2.24 the major change was to the filtering code for Google. In older versions there was an issue if you were filtering to search for old albums, so this version I made a change to make automatic calls when you apply the filtering.

    Since you are displaying most of your albums, would you consider using an exclusion filter? Basically when you are filtering, pick the option to show all albums except the ones that you have selected?

    When I wrote my answer about the number of albums and saw how long the shortcode is, I had the exact same thought, why am I using it like this? 😀
    I was not sure if there is an exclusion filter option but now that I am sure about it, I will try it soon with v2.24!

    Thanks for the help! 🙂

    Plugin Author Sayontan

    (@sayontan)

    This is the relevant option:

    I see that Google has now started imposing a limit per minute, so maybe for the next release I will put an explicit option to disable the automatic pull for these types of requests.

    Yes, I found it, and that gallery is working fine with v2.24 now. However, some others are still problematic (still using the include type filter, but only with 8-10 albums included in them) and I get an error message stating that a certain limit-per-minute quota is exceeded. So the solution is still not perfect, I still have to go back to v2.23 to be fully functional again.

    The option to disable this behaviour, that causes the problem would be great, until then I cannot upgrade the plugin from v2.23.

    • This reply was modified 9 months, 3 weeks ago by thugyecz.
    Plugin Author Sayontan

    (@sayontan)

    I have addressed this in version 2.25, which works as 2.23 did. There is now an explicit option (Photonic → Settings → Google Photos → Google Photos settings → Chain queries) to mimic the behaviour of 2.24, which you can keep unselected.

    I think I’ve stumbled across this while addressing a similar issue. The error I get is:

    Failed to get data. Error:
    Quota exceeded for quota metric ‘photoslibrary.googleapis.com/read_requests’ and limit ‘ReadsPerMinutePerUser’ of service ‘photoslibrary.googleapis.com’ for consumer …

    and seemed to happen after I checked the Chain Queries option in an attempt to solve another problem.

    Rather than mess up this Resolved thread with a similar query I’ll start a new thread. It was the Reads per minute quota that caught my eye.

    • This reply was modified 8 months, 4 weeks ago by dougienisbet.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error code 429 Google Photos’ is closed to new replies.