WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] Error code: -32700 cannot connect social networkgs

[Resolved] Error code: -32700 cannot connect social networkgs

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Jeremy Herve

    @jeherve

    Could you post your site URL, so we can investigate further?

    If you want your site to remain private, you can also contact us here:
    Contact

    Plugin Author Jeremy Herve

    @jeherve

    Thank you. There seems to be an issue with your XML-RPC file:
    http://arongkatz.com/xmlrpc.php

    This file is used by Jetpack to communicate with WordPress.com and activate modules such as Publicize.

    While the message appearing on that page is correct, you’ll notice that there are 2 blank lines above the message. This whitespace can be added by one of your plugins, by your theme, or by some blank lines in your wp-config.php file.

    Once you remove these blank lines, you should be able to use Publicize.

    how can i remove these two blank lines?

    Plugin Author Jeremy Herve

    @jeherve

    These blank lines may be added by a plugin, by your theme, or by your wp-config.php file, if you have added extra “whitespace” (new lines, spaces, tabs, …) before the first <?php or after the last ?> in the file.

    I would recommend switching to a different theme and see of that helps. If it doesn’t, try deactivating all your plugins once by one. And if the issue is not caused by a plugin, have a look at the wp-config.php file.

    I cant switch the theme, i already based all my work on this theme, and i already tried disabling plugins one by one, so i think i need to take a look at the wp-config.php file

    let me see if i can find anything regarding what you are saying about the <? stuff

    Already checked the wp-config file and there are no spaces or lines before the <? and after the ?>

    any other options?

    Plugin Author Jeremy Herve

    @jeherve

    If the issue is not linked to wp-config.php, nor to any of your plugins, it must be linked to the theme.

    Could you switch to Twenty Eleven for a few minutes, and check if the blank lines disappear? If they do, switch back to your current theme and search for whitespace before or after the php tags in all the template files you have worked on.

    done, now i was able to connect the networks

    one question…will i have this problem when posting if i switch back to my original theme?

    Plugin Author Jeremy Herve

    @jeherve

    As long as the whitespace remains, you will experience issues with all plugins and apps using the XML-RPC file.

    Start by checking your functions.php file; it is a good place to start checking for blank lines and spaces.

    One quickie…how do i disable the sharing buttons on front page where i have the post excerpts?, they take valuable space on my site. I just want the share buttons inside each post not on the excerpts

    thanks¬°

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    You should be able to visit WordPress Dashboard >> Settings >> Sharing and unclick the line that reads “Show Buttons on Front Page, Archive Pages, and Search Results”.

    That should disable share buttons on the front page.

    thanks!¬°

    Hi, I found this thread because I’m having a similar problem on my site, but when I load the page that you pointed to with the two blank whitespace lines, I don’t have them, but I’m getting the same error message when I try to connect a social network.

    Can I get a little help?

    My site is at http://www.ryanpaulsen.ca

    Thanks!

    esmi

    @esmi

    Forum Moderator

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Error code: -32700 cannot connect social networkgs’ is closed to new replies.
Skip to toolbar