WordPress.org

Forums

Jetpack by WordPress.com
[resolved] Error code: -32601 (11 posts)

  1. europeanpolicy
    Member
    Posted 1 year ago #

    This is a fresh wordpress site on a new server. The set up is nginx+varnish on Debian. Whenever I try to enable the Publicize feature so that my posts show up on Twitter and Google Plus, I get the following message:
    Something which should never happen, happened. Sorry about that. If you try again, maybe it will work.
    Error code: -32601

    I would be delighted if this could be fixed because I get over 90% of my traffic from Twitter and I can't use that now.

    Kind Regards

    https://wordpress.org/plugins/jetpack/

  2. It's usually problems with your XML-RPC file, especially since your running on nginx&varnish. Usually fixable by disabling Varnish temporarily. Follow the steps at http://usefulmix.com/wordpress-nginx-varnish-jetpack-xml_rpc-32700-glitch-fix/ and see if that helps.

  3. europeanpolicy
    Member
    Posted 1 year ago #

    A thousand thank yous for this fix Patrick, saved me hours of trying to get it working!

  4. Glad it worked :)

  5. raich
    Member
    Posted 6 months ago #

    We are developing a WordPress multisite to be hosted on our preview server, that is on Amazon EC2 cloud running Ubuntu with varnish cache. For the purpose of development this preview server has been setup as a VirtualHost for my mac environment (with MAMP). I've installed the jetpack thru the network admin. But I get the following error while connecting to WP:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32601
    Try connecting again.

    Error Details: The Jetpack server could not communicate with your site's XML-RPC URL. If you have the W3 Total Cache plugin installed, deactivate W3 Total Cache, try to connect to WordPress.com again, reactivate W3 Total Cache, then clear W3 Total Cache's cache.

    I don't have W3 Total cache, xmplrpc.php works perfectly. I've gone thru the glitch-fix document (http://usefulmix.com/wordpress-nginx-varnish-jetpack-xml_rpc-32700-glitch-fix/ ) but not quite sure if it this is the solution for my case.

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 6 months ago #

    @raich Can you please use Jetpack's Debugger module to send us some more information about your site?

    1) Go to the Jetpack page in your dashboard.
    2) Click on the Debug link appearing at the bottom of the page.
    3) Click the link that says "click here to contact Jetpack support."
    4) Fill in the description box and your name and email address.
    5) Click the "Contact Support" button.

    Thanks!

  7. raich
    Member
    Posted 6 months ago #

    Hi Jeremy,

    I've sent an email to Contact Support.

    Thanks.

  8. raich
    Member
    Posted 6 months ago #

    @Jeremy,

    My Jetpack's Debugger test results:
    TEST RESULTS:

    HTTP: PASS
    HTTPS: PASS
    IDENTITY_CRISIS: PASS
    SELF: FAIL

    SELF
    Array
    (
        [headers] => Array
            (
                [server] => nginx
                [date] => Mon, 17 Nov 2014 18:07:31 GMT
                [content-type] => text/plain;charset=utf-8
                [connection] => close
                [x-pingback] => https://jetpack.wordpress.com/xmlrpc.php
                [expires] => Wed, 11 Jan 1984 05:00:00 GMT
                [cache-control] => no-cache, must-revalidate, max-age=60
                [pragma] => no-cache
                [x-hacker] => Jetpack Test
            )

        [body] => {"error":"Jetpack not connected","error_description":"We were unable to find a Jetpack instance on your site. Please connect Jetpack to your WordPress.com account from within your WordPress admin."}
        [response] => Array
            (
                [code] => 400
                [message] => Bad Request
            )

        [cookies] => Array
            (
            )

        [filename] =>
    )
    I've the Jetpack in my local (in MAC) plugins directory.

    Thanks.

  9. raich
    Member
    Posted 6 months ago #

    @jeremy Just now I've upgraded to jetpack 3.2.1 and it has been installed successfully in the work environment (in mac). But when I go to connect Jetpack with wordpress I still get the same xmlrpc 32601 error.

  10. raich
    Member
    Posted 6 months ago #

    @Jeremy

    my .htaccess has very basic entries:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

  11. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 6 months ago #

    I've sent an email to Contact Support.

    Thanks! We'll check the debug test results and reply very soon!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic