Twitter Widget Pro
error checking your rate limit - only one post showing (5 posts)

  1. satcreative
    Posted 2 years ago #


    We have been using Twitter Widget Pro successfully for about 4 weeks. Then as of this morning it is suddenly only showing one post.

    We have tried re-saving our settings etc but nothing helps. If we select show more that 2 posts (3 or more) the whole feed is blank. Current settings are set to show 2 posts. But only one shows.

    We noticed that in the main settings for the widget there is a message:
    Current API Usage:
    There was an error checking your rate limit.

    What does this mean, and is this the source of the issue?
    Please help.


  2. Aaron D. Campbell
    Plugin Author

    Posted 2 years ago #

    There are two things at play here. If your rate limit is showing that error, then it means that the request to twitter returned an error. I don't know what that error was, but communications between your server and theirs is broken.

    The reason you saw only one in the first place is probably this:

  3. satcreative
    Posted 2 years ago #

    Hi and thanks so much for your reply.
    Any idea how we can find out how/why communication is broken. How would we go about fixing it and what impact does this have on our feed?

  4. Aaron D. Campbell
    Plugin Author

    Posted 2 years ago #

    If your server can't communicate with Twitter, it can't update your feed. There's no real built-in debugging for this, so you'd have to go into the code and take a look at the response you receive around line 308. The code should look like this:

    $limit_url = $this->_api_url . "account/rate_limit_status.json";
    $resp = wp_remote_request( $limit_url );

    And you'll want to change it to something like this and take a look:

    $limit_url = $this->_api_url . "account/rate_limit_status.json";
    $resp = wp_remote_request( $limit_url );
    echo '<pre>',var_dump($resp),'</pre>';
  5. Purelaise
    Posted 1 year ago #

    Hi There,

    I am having the same problem. I cannot for the life of me find that info to change it?

    Thanks in advance. Desperate for a fix have tried EVERYTHING now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Twitter Widget Pro
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic