Support » Theme: News Base » Error: Bootstrap’s JavaScript requires jQuery version 1.9.1 or higher

  • Hello,

    I recently noticed my website with the News Base theme wasn’t loading – the circles animation would continue but no content would appear. In the browser console I noticed the following error:

    Error: Bootstrap's JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3

    Some googling led to discussions on other themes with a similar issue, connected to the wordpress 5.6 update:

      I’ve temporarily worked around this by adding the following at the top of the theme’s functions.php file:

      wp_deregister_script(‘jquery’);
      wp_register_script(‘jquery’, ‘//cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js’, false, null);
      wp_enqueue_script(‘jquery’);

      Has anyone else had this issue? Is there a theme update in the works that will address this? (Sounds like bootstrap itself might need updating?)

      Cheers!

    • This topic was modified 3 months, 2 weeks ago by manmak.
Viewing 2 replies - 1 through 2 (of 2 total)
  • myanesp

    (@myanesp)

    Hi, @manmak:

    I have a childtheme of News Base, but I didn’t notify any issue. Did you find any answer? Or did your workaround just works?

    Thanks in advance.

    Thread Starter manmak

    (@manmak)

    Hi @myanesp, News Base haven’t updated their theme since my original post so I’m guessing the issue still exists. I’m still using my workaround. Mind you, I haven’t updated to WordPress 5.7.1 yet.

    I’m running WP 5.7 which is when the error occurred. If you’re running an older WordPress version it’s probably fine with the current News Base release.

    Hope that helps!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.