Support » Theme: Verb Lite » Error: Bootstrap’s JavaScript requires at least jQuery v1.9.1

  • Resolved userpqr

    (@userpqr)


    After updating WordPress, I get the following errors in browser console:

    Uncaught Error: Bootstrap’s JavaScript requires at least jQuery v1.9.1 but less than v3.0.0
    at theme.min.js?ver=0.4.4:3
    at theme.min.js?ver=0.4.4:3

    I am unable to open the menubar properly. Is it a compatibility issue between verb-lite theme and the latest wordpress?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Thread Starter userpqr

    (@userpqr)

    I did some troubleshooting with the Health Check and Troubleshooting plugin. I can see everything works properly when I change the theme. It looks like it is a conflict with the Verb Lite theme. Please help.

    Thread Starter userpqr

    (@userpqr)

    Is the Verb Lite theme still supported by themely?

    oksana40

    (@oksana40)

    I have the same problem. I solved it like this:

    In function.php your theme add –

    wp_deregister_script(‘jquery’);
    wp_register_script(‘jquery’, ‘//cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js’, false, null);
    wp_enqueue_script(‘jquery’);

    Thread Starter userpqr

    (@userpqr)

    Thanks @oksana40 But the problem is if Verb Lite has stopped supporting the theme, we cannot use it anymore.

    Theme Author themely

    (@themely)

    Hello @userpqr and @oksana40

    My apologies for the late reply.

    @oksana40 thank you for providing your solution.

    We have stopped updates on Verb Lite and since the latest update is more than 2 years old any new updates we release must go through the new theme approval process which can take months.

    If you have any other issues we will be happy to help resolve.

    Thread Starter userpqr

    (@userpqr)

    Thanks @themely for the response. Is there any possibility that we get the update?

    Theme Author themely

    (@themely)

    Hello @userpqr

    What @oksana40 did was the correct solution.

    An update would do the exact same thing.

    Thread Starter userpqr

    (@userpqr)

    Hi @themely and @oksana40

    Thanks for the solution. I added the same script in the function.php of the theme. I still keep getting the error:

    Uncaught Error: Bootstrap’s JavaScript requires at least jQuery v1.9.1 but less than v3.0.0
    at theme.min.js?ver=0.4.4:3
    at theme.min.js?ver=0.4.4:3

    I am adding the following lines in function.php: (at the end of the file)

    wp_deregister_script(‘jquery’);
    wp_register_script(‘jquery’, “//cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js”, false, null);
    wp_enqueue_script(‘jquery’);

    Am I missing anything? Please note that I am using a child theme.

    • This reply was modified 11 months, 3 weeks ago by userpqr.
    Thread Starter userpqr

    (@userpqr)

    I added the following scripts in functions.php:

    function myfunction() {
    if(!is_admin()) {
    wp_deregister_script(‘jquery’);
    wp_register_script(‘jquery’, ‘https://cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js’, false, false, true);
    wp_enqueue_script(‘jquery’);
    }
    }
    add_action(‘wp_enqueue_scripts’, ‘myfunction’);

    It works. But, sometimes I am getting the following error:

    Uncaught TypeError: s.event.addProp is not a function
    jQuery 3
    fix
    dispatch
    handle

    And, sometimes it says, jquery not defined. Please help.

    • This reply was modified 11 months, 3 weeks ago by userpqr.
    • This reply was modified 11 months, 3 weeks ago by userpqr.
    Theme Author themely

    (@themely)

    Hello @userpqr

    Can you share the link to the site so I can have a look?

    Thread Starter userpqr

    (@userpqr)

    Hi @themely Thanks for the response.

    I changed wp_register_script(‘jquery’, ‘https://cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js’, false, false, true) to wp_register_script(‘jquery’, ‘https://cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js’, false, null) and it is working now.

    Theme Author themely

    (@themely)

    @userpqr great, glad it’s working now.

    I have added this code to functions.php and it works perfectly. The same thing happened to me in some other theme and it has also worked.

    add_action('wp_enqueue_scripts', 'mitheme_enqueue_scripts'); 
    function mitheme_lite_enqueue_scripts() { wp_deregister_script('jquery'); wp_register_script('jquery', ("https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"), false, null); wp_enqueue_script('jquery'); }

    Great job Raul, thanks!

    Hi Raúl Pérez Caballero ,

    your code does not work because of the name of the function which is different between declaration (mitheme_lite_enqueue_scripts) and registration (mitheme_enqueue_scripts). Here is the same code with harmonized names :

    add_action('wp_enqueue_scripts', 'myfct_enqueue_scripts'); 
    function myfct_enqueue_scripts() { wp_deregister_script('jquery'); wp_register_script('jquery', ("https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"), false, null); wp_enqueue_script('jquery'); }
Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.