Support » Plugin: Postman SMTP Mailer/Email Log » Error: Bad Request(invalid_grant)

  • Installed, setup, and have been using Postman since last year with no issue. Have been away from the site for a while and in coming back it is not sending.

    When running a test email get this error: Bad Request(invalid_grant)

    Ran through the set up wizard and gmail Oath still has the same client and ID and Secret. Other settings…

    security is STARTTLS
    authentication is Oath 2.0

    Diagnostic Test:

    OS: Linux ps380115 3.1.9-vs2.3.2.5vs2.3.2.5+ #3 SMP Wed Feb 12 13:51:29 PST 2014 x86_64
    PHP: Linux 5.6.24 C
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=Yes, zlib_encode=Yes
    WordPress: 4.6.1 en_US UTF-8
    WordPress Theme: Implicit
    WordPress Plugins: AdRotate Professional, AWeber Web Forms, helper, Business Directory Plugin – Claim Listings Module, Business Directory Plugin – Featured Levels Module, Business Directory Plugin – Google Maps Module, Business Directory Plugin – PayPal Gateway Module, Business Directory Plugin, Business Directory Plugin – Ratings Module, Business Directory Plugin – Regions Module, Business Directory Plugin – ZIP Search Module, Facebook Comments Plugin, Official Mad Mimi Signup Forms, Mashshare Share Buttons, NextGEN Gallery, Ninja Forms, Postman SMTP, Pretty Link Lite, Sweet Captcha, Social Media and Share Icons (Ultimate Social Media), WP Super Cache
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email
    WordPress wp_mail_from_name Filter(s): swtcptcf_email_name_filter
    Postman: 1.7.2
    Postman Sender Domain (Envelope|Message): |
    Postman Prevent Message Sender Override (Email|Name): No | No
    Postman Active Transport: SMTP (smtp:tls:oauth2://
    Postman Active Transport Status (Ready|Connected): Yes | Yes
    Postman Deliveries (Success|Fail): 1951 | 37

    Transport Socket Status* Service Available Server ID Authentication
    None Login Plain CRAM-MD5 OAuth 2.0
    SMTP Open 🔒 SMTP-STARTTLS No Yes Yes No Yes
    SMTP Open 🔒 SMTPS No Yes Yes No Yes
    SMTP Open 🔒 SMTP-STARTTLS No Yes Yes No Yes
    Gmail API Open 🔒 HTTPS n/a
    Mandrill API Open 🔒 HTTPS n/a
    SendGrid API Open 🔒 HTTPS n/a
    * According to


    ✅ 🔒 Port 443 can be used with the SendGrid API.
    ✅ 🔒 Port 587 can be used for SMTP to
    ✅ 🔒 Port 25 can be used for SMTP to
    ✅ 🔒 Port 443 can be used with the Gmail API.
    ✅ 🔒 Port 443 can be used with the Mandrill API.
    ✅ 🔒 Port 465 can be used for SMTP to

Viewing 3 replies - 1 through 3 (of 3 total)
  • SAME issues started a week ago.

    everything says Bad Request(invalid_grant)

    Any Ideas what’s up?

    Kim White

    Same issue for me, it started happening 2-3 weeks ago with no changes made to the settings or website. Anyone have a fix?

    Reauthenticate with Google. For some reason the connection was removed and simply needs to be redone.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error: Bad Request(invalid_grant)’ is closed to new replies.