Support » Plugin: CF Geo Plugin - WordPress Geo Plugin » Error: Arrays are not allowed in class constants

  • Resolved rpgmyxa

    (@rpgmyxa)


    After updating the plugin I’ve got error message:

    Fatal error: Arrays are not allowed in class constants in ***/www/wp-content/plugins/cf-geoplugin/includes/class-cf-geoplugin-global.php on line 123

    PHP ver 5.4

    How can I resolve that?

    • This topic was modified 1 year, 6 months ago by rpgmyxa.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Ivijan-Stefan Stipic

    (@ivijanstefan)

    Hello,

    Thank you for using CF GeoPlugin.

    In the description of the plugin you will notice “PHP Version: 5.6.0 or higher”, that mean your PHP version is a bit older (PHP 5.4) and plugin not support it.

    Solution for this is PHP upgrade to 5.6 or higher. We recommended 7.1 or 7.2 but your WordPress must be upgraded and all other plugins too. If you are not sure and want to be safe, use 5.6 and you will not have any kind of problems.

    NOTE: Before changing PHP versions, made backup of your project.

    Same problem… I updated to PHP 5.6 on my server, but I still get the same error message when trying to activate.

    Fatal error: Arrays are not allowed in class constants in ***/wp-content/plugins/cf-geoplugin/includes/class-cf-geoplugin-global.php on line 123

    I purged all my caches just in case that mattered, but didn’t help.

    Plugin Author Ivijan-Stefan Stipic

    (@ivijanstefan)

    If you upgrade to PHP5.6 must work.

    Here is example of that problem.

    http://sandbox.onlinephpfunctions.com/code/d50f416563c2b5cfa163f2f242f520ab54762a46

    If you put below PHP5.6 will generate error. If you put PHP5.6 will work fine. Something is not running well on your server.

    Please double check or call system administrator.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error: Arrays are not allowed in class constants’ is closed to new replies.