Error appeared while upgrading to Oscar (7 posts)

  1. guusterbeek
    Posted 3 years ago #

    Hi, I got this error while upgrading to the latest WordPress version Oscar:

    Fatal error: Cannot redeclare wp_convert_bytes_to_hr() (previously declared in /home/guusterb/domains/guusterbeek.nl/public_html/wp-includes/deprecated.php:3364) in /home/guusterb/domains/guusterbeek.nl/public_html/wp-includes/media.php on line 1146

    My whole site is down and just shows this error. This is my website http://www.guusterbeek.com

    Any got any solutions? Thanks!

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    - switching to the default theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    - running the upgrade manually via wp-admin/upgrade.php

  3. guusterbeek
    Posted 3 years ago #

    Thanks Esmi. I fixed it.

  4. d33k
    Posted 3 years ago #

    @guusterbeek did you fix it by using the steps he mentioned? I'm having a very similar issue that I can't seem to resolve.

  5. guusterbeek
    Posted 3 years ago #

    Hi d33K,

    What I did was manually replacing WordPress on my webhost. Replace all files except your wp-content and the wp-config.php. But you don't need to worry about that because the wp-config file in the wordpress download is called wp-config-sample.php so it won't overwrite your original file.

    When done, visit the website and run the upgrade again. Worked perfectly for me. I had to refresh the permalinks thouhg, because my portolio urls weren't working. If you have the same problem too, got to settings/permalinks and refresh. That's it.

  6. d33k
    Posted 3 years ago #

    @guusterbeek thanks man, that helped.

    I reuploaded the entire wordpress install, less the wp-content directory and the site worked fine. The first time I logged into the admin section it said the database needed upgrading, but it only took about 1 second and was complete. All sorted out again.

    EDIT: I posted too soon. Seems clicking a post from the main page will give me a 404 not found error. I did the perma-link settings save as you suggested, but it didn't resolve the issue. It said "You should update your web.config now." when I did this.

  7. Pentame
    Posted 2 years ago #

    Thankyou All,
    I was having the similar issue after updating my wordpress site. After replacing all the files and folder except wp-content and wp-config.php in root with a fresh wordpress files and folders, It resolved the issue and the site is working fine. Thanks a lot for all your support.

Topic Closed

This topic has been closed to new replies.

About this Topic