Support » Plugin: Wordfence Security - Firewall & Malware Scan » ERROR: An error was encountered while trying to authenticate. Please try again.

  • Resolved Martin1

    (@martin1)


    Hi all,

    I have read through a lot of posts and see that I am not the only with this issue.

    I set up 2fa (no captcha or anything just 2fa) and now I and my client get the warning:

    “ERROR: An error was encountered while trying to authenticate. Please try again.”

    It did work for two days. But not anymore.

    I have set it up for two admins (one admin and one subscriber hasn’t been setup yet).

    For myself and my client I added our IP addressess so we didn’t need to use the 2fa.

    Why are we now getting this error?

    I just tried it in another browser (Edge) and it works fine which makes it even weirder. Why doesn’t it work in my browser Firefox?

    Could it have something to do with the Limit Login Attempts Reloaded plugin which is also installed?

    • This topic was modified 5 months, 2 weeks ago by .
    • This topic was modified 5 months, 2 weeks ago by .
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support WFAdam

    (@wfadam)

    Hello @martin1 and thanks for reaching out to us!

    If you are running the Limit Login Attempts plugin and are using our Two Factor Authentication, the first login (username and password only) that sends our code is counted against the total that the Limit Login Attempts plugin uses to determine if you will be locked out. This should be addressed in the next Wordfence release. Please also be aware that the Limit Login Attempts plugin is unsupported, hasn’t been updated since 2012, and isn’t even listed as compatible with any WordPress version past 3.3.2.

    As always, Wordfence would like to remind you that using outdated, unsupported plugins is not recommended and puts your site at risk.

    Try to disable that plugin and test 2FA again. Our Brute Force Protection should help limit your login attempts.
    https://www.wordfence.com/help/firewall/brute-force/

    Let me know if you have any questions!

    Thanks!

    Thread Starter Martin1

    (@martin1)

    I am sure it doesn’t make a difference but it’s not Limit Login Attempts that is being used but Limit Login Attempts Reloaded https://wordpress.org/plugins/limit-login-attempts-reloaded/ which is up-to-date.

    But I will remove it and try again :-).

    Wordfence installed with 2FA, and now the login page for your wordpress won’t work.

    This is marked as resolved, but here is another quick trick that might work for you. I was finding all kinds of directions, most of which involved coding, deleting plugins, etc. If I deactivated wordfence, it would work, but that defeats the purpose of having wordfence.

    I figured this out today, and it works on my site. There is no coding, and it’s quicker than my long winded explanation. This was driving me crazy all day until I was messing around and figured this out.

    Steps:
    try to log in as usual: (replace “yoursite” with your domain of course)
    https://www.yoursite.com/wp-login.php?
    enter your userid and password, hit enter.
    You will get the response:
    “ERROR: An error was encountered while trying to authenticate. Please try again.”

    now, SCROLL DOWN and click the “Lost your password?” link.

    On that page, don’t fill anything in, leave the email field blank, but SCROLL DOWN AGAIN, and click the “Log In” link.

    It should take you right back to the regular log in page. Try to log in again….

    Not sure why this works, but it does. I’m using Firefox with Win10. It’s weird, but it works. I’ve tested it like a dozen times and the regular log in will not work every single time. BUT… if I do the above trick, it works EVERY SINGLE TIME.

    What’s even crazier….. I’ve been getting tons of hack attempts showing up in wordfence. BUT, since my normal method of logging in won’t work anymore, I’m not getting any failed log in attempt notifications. Maybe they can’t log in either, and now only I can with the method above.

    Anyway, hope it works for you. Only takes a second, so might as well give it a shot.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.