Support » Plugin: Redis Object Cache » Error after upgrading to version 1.5.0

  • Resolved wfstudents

    (@wfstudents)


    Hi,

    Thanks for the plugin…

    I just upgraded and it took down my site.. had stop Redis on server to recover..

    Error log:

    [error] 19635#19635: *359939 FastCGI sent in stderr: “m/wp-includes/class-wp-post.php on line 265PHP message: PHP Warning: Invalid
    argument supplied for foreach() in /var/www/example.com/wp-includes/class-wp-post.php on line 265PHP message: PHP Warning: get_object_vars
    () expects parameter 1 to be object, array given in /var/www/example.com/wp-includes/class-wp-post.php on line 265PHP message: PHP Warning:
    Invalid argument supplied for foreach() in /var/www/example.com/wp-includes/class-wp-post.php on line 265PHP message: PHP Warning: get_obj
    ect_vars() expects parameter 1 to be object, array given in /var/www/example.com/wp-includes/class-wp-post.php on line 265PHP message:

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    You upgraded from 1.4.3 to 1.5.0?

    Plugin Author Till Krüss

    (@tillkruess)

    Did you switch to the JSON serializer?

    Yes, upgraded from 1.4.3 to 1.5.0

    If JSON serializer means to add this line in my wp-config.php file, then yes..

    define( ‘WP_REDIS_SERIALIZER’, Redis::SERIALIZER_JSON );

    I scratch my head on that. wp-config.pho should be loading earlier than redis plugin. Therefore the class Redis is not yet available. Then error 500 seems a reasonable result.

    Maybe the JSON serializer should be set elsewhere?

    leonardorodriguez

    (@leonardorodriguez)

    I have the same issue

    Updated redis from 1.4.3 to 1.5

    added define( ‘WP_REDIS_SERIALIZER’, Redis::SERIALIZER_JSON ); to wp-config

    site down

    I did the same mistake and enabled the JSON serializer. Now my database is all screwed up because get_option returns a JSON object when some plugins are expecting arrays. Please advise as to how to recover.

    in my case I did a server reboot after commenting the wp-config.php line

    I had to rollback to yesterday’s backup to recover. I am going to hold off on the 1.5.0 upgrade until I see a good explanation and solution to the issue.

    I have the same issue too.
    Remove define( ‘WP_REDIS_SERIALIZER’, Redis::SERIALIZER_JSON ); useFLUSHALLproblem solved.
    By the way, using IGBINARY serializer has the same problem.

    I had this database problem even before this upgrade, but then I got a backup and installed again and it worked, but I was not able to fix it after the error happened. After update the plugin I had the same issue and I am wondering if I loose my work day today or not.
    Is it possible to maybe delete something on the DB to get it working again? Tks!

    I’ve tried the upgrade released today as well on 3 different sites and servers. If I include the specified define() in the wp-config file it breaks the site. Doesn’t matter if it’s at the beginning or the end of the file.

    If I leave the define() out I’m able to get to the diagnostic page for Redis Object Cache and see that it’s not able to connect to the Redis server on localhost. If you’re having this problem you might want to see if the plugin is communicating with your Redis instance.

    That is what appears:
    Status: Disabled
    Client: pecl
    Drop-in: Invalid
    Redis Extension: 5.0.2
    Predis Client: 1.1.1
    PHP Version: 7.2.23
    Multisite: Yes
    WP_REDIS_CLIENT: “pecl”
    WP_REDIS_HOST: “localhost”
    WP_REDIS_PORT: “6379”
    WP_REDIS_MAXTTL: “86400”
    Dropins:
    – advanced-cache.php v by

    But even after I downgraded the plugin and tried to activate it, it still crashes the database, I get my sites back just after to rename object-cache.php file.

    I am personally not clear at to what the proper plugin upgrade and plugin settings change protocols are. Am I supposed to flush the cash and disable the object cache before making any changes and then re-enable it? A how-to guide would be very much appreciated (or pointer to the guide if it already exists).

    Did you guys get Redis working alright again? When this error happened during the previous installation I needed to restore the backup, I feel something and crashed on DB.

    On my wp diagnostic shows this warnings, I am wondering if my issue is somehow related with them:

    The REST API is one way WordPress, and other applications, communicate with the server. One example is the block editor screen, which relies on this to display, and save, your posts and pages.
    The REST API request failed due to an error.
    Error: [] cURL error 60: Peer’s Certificate has expired.

    Loopback requests are used to run scheduled events, and are also used by the built-in editors for themes and plugins to verify code stability.
    The loopback request to your site failed, this means features relying on them are not currently working as expected.
    Error: [] cURL error 28: Operation timed out after 10001 milliseconds with 0 out of -1 bytes received

Viewing 15 replies - 1 through 15 (of 26 total)
  • You must be logged in to reply to this topic.