WordPress.org

Support

Support » Installation » [Resolved] Error after upgrading to 3.4 – custom-background.php on line 16

[Resolved] Error after upgrading to 3.4 – custom-background.php on line 16

  • The complete error message is:

    Fatal error: Cannot redeclare class Custom_Background in /path/wordpress/wp-admin/custom-background.php on line 16

    That’s all I get on a nice white background.

    Rolled back to 3.3.2.

    What should I do to fix this?

    thanks in advance,
    alan

Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi

    @esmi

    Forum Moderator

    Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    What should I tell the theme developer to look for assuming that fixes it – won’t be able to test it until the weekend.

    And thanks,
    alan

    esmi

    @esmi

    Forum Moderator

    S/he needs to look at the changes that have been made in WordPress since the theme was last updated.

    Theme author was contacted and has released a newer version which others say has resolved the issue. I’ll try again tomorrow.

    Thanks,
    alan

    I have just had the same problem, but I don’t know how to literally do anything with my website now?!

    You said you rolled back to the previous version how can I do this? As soon as I try to log in as admin for my site I just get the error page.

    Thanks 🙂

    esmi

    @esmi

    Forum Moderator

    Please post your own topic.

    I do not know how to change my current blog themes to earlier versions, because I can not log into my blog.
    Every login, there is always the message: Fatal error: Can not redeclare class Custom_Background in / home2/situsonl/public_html/wp-admin/custom-background.php on line 16

    Moderator cubecolour

    @numeeja

    ɹoʇɐɹǝpoɯ

    situs, Please post your own topic. this one has already been marked as resolved

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Error after upgrading to 3.4 – custom-background.php on line 16’ is closed to new replies.
Skip to toolbar