Support » Plugin: Advanced Access Manager » Error after upgrading from version to 2.0

  • Resolved elektroinside



    First of all, absolutely great plugin! As i mentioned in my review, it’s a “life saver”! Thank you for your effort!

    I recently tried to upgrade from to 2.0, and everything looked good, even the migration, until i clicked on ‘Metaboxes and widgets’. At the first look, nothing happened, the list was not populated after a refresh. There was no data even before i hit refresh in the list. Then, i tried to debug, as much as i could, what went wrong.

    I have the error below every time i try to refresh metaboxes and widgets:

    WordPress database error MySQL server has gone away for query SELECT option_value FROM wp_options WHERE option_name = ‘aam_metabox_cache’ LIMIT 1 made by do_action(‘wp_ajax_aam’), call_user_func_array, aam->ajax, aam_View_Ajax->run, aam_View_Ajax->loadMetaboxes, aam_View_Metabox->retrieveList, aam_View_Metabox->buildMetaboxList, aam_Core_API::getBlogOption, get_option

    Then i tried to find ‘aam_metabox_cache’ in my db, but there is no field or property or description or anything by this name. Then i tried to run the query “SELECT option_value FROM wp_options WHERE option_name = ‘aam_metabox_cache’ LIMIT 1” manually in phmyadmin, but the query returned NULL. And that’s it, i don’t know what else to do.

    Before the upgrade i had the list of metaboxes and widgets populated, but after the upgrade it vanished, and the refresh is generating the error above.

    What else can i try or do?

    Many thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello again,

    Have you managed to look into my problem? Is there something obvious i’m missing? It might be the caching feature of AAM which is causing my issue.. Is there a way to disable caching in AAM?

    Thank you!

    Plugin Author Vasyl Martyniuk


    Hi elektroinside,
    Sorry for late response. We’ve been checking your issue and we were not able to reproduce it.
    I do not believe that this has anything to do with SQL query. There must be some other issue.
    Is there any change to check for JavaScript errors and PHP error log?



    I activated advanced access manager on a clients site. I got a message asking if it could migrate existing data to newer version, so I said yes. Now even tho I am admin, I cannot access much of the dashboard. So I removed the AAM directory from plugins via ftp, and then installed the developer version via cpanel, but still cannot access everything. I did get a AAM on the dashboard but it doesnt seem to allow me to add capabilities, very confusing. At any rate i am at a loss how to fix this and get back to making this website. of course i failed to take a backup before turning this on, thinking it was no big deal. Someone please help!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error after upgrading from version to 2.0’ is closed to new replies.