Support » Plugin: Events Manager » Error after upgrades: headers already sent

  • Resolved vocalist

    (@vocalist)


    Hi
    The events manager worked perfectly but since the latest upgrades noticed that when I or a member goes to add an event I get a blank page with the following error message:

    Warning: Cannot modify header information – headers already sent by (output started at

    (output started at /home/…../public_html/wp-content/plugins/events-manager/classes/em-location.php:201) in /home/……/public_html/wp-admin/post.php on line 198

    and

    (output started at /home/…./public_html/wp-content/plugins/events-manager/classes/em-location.php:201) in /home/…./public_html/wp-includes/pluggable.php on line 1216

    When I click ‘back’ on the browser – it sometimes creates another ‘new’ empty event form or takes me to the one I have just tried to add – BUT when I look at the events list – the event I received the error for has been successfully created.

    I could live with the issue if it was only me adding events, but my site is aimed at teachers and allows members to add their own events – they get very confused when things don’t work properly so would appreciate any advice you can give on fixing this – I am not very techie when it comes to scripts – coped MUCH better before WP changed to the useless templating system 🙁

    Thanks

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support caimin_nwl

    (@caimin_nwl)

    NetWebLogic Support

    Hi,

    It’s possible this is a conflict caused by your theme or another plugin. To check if it is, can you test with all other plugins deactivated and while running the default WordPress theme?

    Are you using BuddyPress? If so, which version are you using?

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    There might be more PHP notices/errors associated with this too, if you can see them please paste them here.

    The line mentioned there is unlikely to be the culprit, I suspect it could be another plugin/theme interfering.

    If you do notice that a plugin is causing problems, I’d suggest reporting it to the plugin author, and meantime just disable the display_errors PHP setting so the errors don’t prevent your site from functioning.

    Hi
    Thanks for the responses, unfortunately this is a working site and unable to turn all the plugins off and change the theme as afraid to lose everything!

    I am running events manager Version 4.9.4

    Everything worked fine up until the last version upgrade

    I have not seen any other PHP notices or errors – only when an event is added – I am not getting any errors or problems with any other plugin or the theme – only this one and only since the last time the events manager plugin was upgraded.

    I have no idea how to disable the display_errors php setting and the errors aren’t preventing the site from working – only get them when the Publish button is clicked to add an event.

    I don’t use BuddyPress at all.

    Marcus – the forum here is showing you as the/a plugin author – if you are not then not sure how to report this to the plugin author – thought this was the support forum for the free version and it states on their site that they only provide support via the forums 🙁

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    This is the right place. We can try and reproduce, but if we can’t, it may well be plugin/theme conflict you have to test (I may have a solution for testing without disabling though)

    What do you do specifically to add an event which triggers this error:

    Admin area or front-end?
    Whilst adding the event, do you create a new location, choose ‘no location’, select one from a dropdown (if you have that enabled) or use the autocomplete to find your location?

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    One more thing… are you using Multisite? If so:

    Are you using global tables mode?
    If so, is the location you choose possibly located on a different blog to the one where you’re creating an event?

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Ignore my previous comments. I’ve managed to reproduce this and will fix it for the next update.

    I should add though that if you disable the display_errors directive in PHP, this kind of thing won’t happen. Also, it’s recommended you do so for security purposes.

    Hi Marcus,
    Thanks for the responses – in answer to your questions

    The error occurs when adding a new location and when using autocomplete to add an existing location – haven’t had to add an event without a location so no idea if it happens then as well. I always use the admin backend to add events – it is possible to add events from the front end but i haven’t tested that since the issue started as so used to do the adding via backend that i forget the frontend completely!

    I am not using multisite so no global modes

    No idea how to disable anything in PHP – that is down to my server tech friend – who is normally pretty hot on turning anything that even hints at being a security risk so surprised if that is turned on but will mention it to him.

    Thanks for the help, I look forward to the fix in the next update.

    Kind regards
    Tracey

    Plugin Support angelo_nwl

    (@angelo_nwl)

    NetWebLogic Support

    you can try and confirm the latest EM version 5.9.2

    dionadk

    (@dionadk)

    I am getting a error notice:
    “Notice: Trying to get property of non-object in /srv/bindings/90430e328367413087e38464412481a0/code/wp-content/plugins/events-manager/classes/em-event-post.php on line 132 Notice: Trying to get property of non-object in /srv/bindings/90430e328367413087e38464412481a0/code/wp-content/plugins/events-manager/classes/em-location-post.php on line 96”

    I am using Interactive Map of the USA for WP plugin. This error is showing on My maps page when I click on a state. If I deactivate the Events Manager plugin I don’t get this error. I need to use both the plugins. Any help to resolve this error is appreciated. Thanks in advance

    • This reply was modified 1 month ago by  dionadk.
    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Hi @dionadk,

    Your issue is unrelated to this topic, so you should post a new one in this sort of situation.

    However, what I can say is those lines in your error are pretty standard WP practice and not something we’d need to fix. If errors are being thrown due to that other plugin (i.e. it goes away when you deactivate the other one), then it’s doing something wrong.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.