Error after upgrade to 2.8 (4 posts)

  1. rosscarlson
    Posted 7 years ago #

    One of our users just clicked the "upgrade" button in the WP Admin interface (we were on 2.7) and now we're getting the following error in our PHP logs:

    PHP Fatal error: Call to a member function read() on a non-object in /home/feld/public_html/wp/wp-includes/theme.php on line 387

    I've removed all the plugins manually and that didn't help, I'm guessing it's something in the themes but I'm not sure where to start looking. Any ideas? The site is working currently but the admin tools aren't (so we can't post).



  2. coolgates
    Posted 7 years ago #

    Getting this exact same error after upgrading to 2.8. Any solutions?

  3. coolgates
    Posted 7 years ago #

    This solution worked for me.

  4. brandon_rhodes
    Posted 6 years ago #

    @coolgate's solution, unfortunately, did not work for me, but made parts of the Dashboard disappear. I solved the problem by looking at the sub-directories of my theme, and noticing that one was unreadable: the ".svn" hidden directory that Subversion, by version-control system, had created. Once I set it world-readable so my "www-data" user could see it, WordPress started working fine again.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.