Support » Plugin: Duplicator - WordPress Migration Plugin » error after upgrade Duplicator from 1.2.0 to 1.2.4

  • Resolved jpgoem

    (@jpgoem)


    After upgrading Duplicator from 1.2.0 to 1.2.4, I get the following error when trying to create a new package : Fatal error: Uncaught exception ‘Exception’ with message ‘There is no suitable CSPRNG installed on your system’ in C:\xxx
    \iwpserver\htdocs\wordpress\wp-includes\random_compat\random.php:205

    Stack trace:
    #0 C:\xxx\iwpserver\htdocs\wordpress\wp-content\plugins\duplicator\classes\package\class.pack.php(423): random_bytes(8)
    #1 C:\xxx\iwpserver\htdocs\wordpress\wp-content\plugins\duplicator\classes\package\class.pack.php(320): DUP_Package->makeHash()
    #2 C:\xxx\iwpserver\htdocs\wordpress\wp-content\plugins\duplicator\views\packages\main\new2.scan.php(20): DUP_Package->saveActive(Array)
    #3 C:\xxx\iwpserver\htdocs\wordpress\wp-content\plugins\duplicator\views\packages\main\controller.php(41): include(‘C:\xxx\…’)
    #4 in C:\xxx\iwpserver\htdocs\wordpress\wp-includes\random_compat\random.php on line 205

    I deleted and reinstalled 1.2.4, same result. Problem does not appear after fallback to 1.2.0.

    Running on Windows 10 with InstantWP 4.5 with WordPress 4.7.3 / Apache/2.2.15 (Win32) / PHP/5.3.2 / MySQL 5.6.25

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @jpgoem,

    Thanks for the feedback! If you can give the developer version a try it may have the updates for your issue. The very latest version (1.2.5) can be found by following these instructions:

    -> Download Latest Version
    -> Uninstall your current version and install this one.

    Let me know if this solves your issue~

    Thanks

    • This reply was modified 2 years, 6 months ago by  Cory Lamle. Reason: link

    Hello Cory,

    The latest version (1.2.5) solves the problem.
    Thanks a lot for your quick and efficient support !

    Plugin Author Cory Lamle

    (@corylamleorg)

    Excellent! Thanks for the update…

    Thanks Cory – I had the same error, followed your instructions above and its all working as expected.
    cheers
    Campbell

    Plugin Author Cory Lamle

    (@corylamleorg)

    Thanks for the info @smythec! The change will be going out in the next release…

    Cheers~

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘error after upgrade Duplicator from 1.2.0 to 1.2.4’ is closed to new replies.