Support » Plugin: Yoast SEO » Error after Upgrade

  • Resolved saimrasheed

    (@saimrasheed)


    I am receiving errors in the rror log after updating Yoast. The error is

    PHP Warning: Illegal string offset ‘width’ in /home4/s8l6zzck/opportunitiescorners.info/wp-content/plugins/wordpress-seo/frontend/schema/class-schema-image.php on line 149

    [30-Apr-2019 12:01:17 UTC] PHP Warning: Illegal string offset ‘height’ in /home4/s8l6zzck/opportunitiescorners.info/wp-content/plugins/wordpress-seo/frontend/schema/class-schema-image.php on line 150

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Support benvaassen

    (@benvaassen)

    Hi there,

    I’m sorry to see you have these warnings show up on your website. They shouldn’t show up and we shouldn’t create them. The warnings on your frontend should go away if you disable WP_DEBUG in your wp-content.php.

    I’m trying to reproduce the warnings, yet I’m unable to do so with a default theme, like Twenty Nineteen. Can you report this issue on GitHub so we can prevent these warnings? Link to GitHub: https://github.com/Yoast/wordpress-seo/issues?

    I Need to ask Few Questions:

    1) why should i disable wp debug?
    2) would Disabling Wp Debug will create any other Problems?
    3) is this necessary to disbale wp debug?

    4) these errors arised after updating Yoast. I will put this issue on github

    Please help me here. I do not know how to create a Post on Github.

    I have already told my issue here. And i know may users are facing this issue after updating

    Secondly, Wp_debug is in Wp.config.php file
    And u said inside wp_content.php

    Where is wp_debug file and how to disable that

    Plugin Author Taco Verdonschot

    (@tacoverdo)

    @saimrasheed, You are right that Ben mentioned the wrong file. WP_DEBUG is indeed defined in the wp-config.php file.

    WP_Debug is used to debug problems on your website. By setting WP_Debug to true, you’re outputting all notifications and warning on the front-end of your website. This can be useful if you’re actually are debugging, but may lead to unwanted messages on your site and in extreme cases even to security vulnerabilities.

    Disabling WP_Debug shouldn’t create any new/other issues on your site.

    No, it’s not _necessary_ to disable WP_DEBUG. Doing so just disables the display of this warning on your website that is currently defacing your website.

    If you want to resolve the cause of the warning instead of just stopping it from being displayed, we strongly suggest you do a full conflict check, as described in our knowledge base: https://kb.yoast.com/kb/how-to-check-for-plugin-conflicts/.

    Thanks for the Great Reply.
    Reqlly Appreciated.

    Did you obsered that Many Users are facing this issue after an Update of Yoast. Do you think is this problem in Yoast Update?

    How we can encounter that Problem?

    i have saw that wp_debug is already set to disbale. define(‘WP_DEBUG’, false);

    my error log is full of these errors frontend after yoast update

    Yes. My website logo is alrrady in PNG.

    Still warnings are coming
    Wp debug is also turned off
    Still warnings.

    Just wanna ask will these warnings will destroy something?

    Have u people noted any changes in the website due to these warnings?

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    The author has stated this to disable front-end errors:

    WP_Debug is used to debug problems on your website. By setting WP_Debug to true, you’re outputting all notifications and warning on the front-end of your website. This can be useful if you’re actually are debugging, but may lead to unwanted messages on your site and in extreme cases even to security vulnerabilities.

    Plugin Author Taco Verdonschot

    (@tacoverdo)

    So there’s two different things happening here.

    1. The warning being thrown at all is something we worry about. It probably means that there is a plugin conflict, and we’ll need additional information to research and resolve that. That’s why I asked for the results of this conflict check: https://kb.yoast.com/kb/how-to-check-for-plugin-conflicts/

    2. The warning being shown on your website. This is _most likely_ due to the configuration of your website, and not related to Yoast SEO. If you can please share a URL where this is happening for you, I’d be happy to check the source of your page to verify this error doesn’t come from within Yoast SEO.

    Thanks for your help.

    Plugin Author Taco Verdonschot

    (@tacoverdo)

    Update:
    We’re pretty sure we’ve found the source of the warning. Given that it’s just a warning, and nothing breaks on your website, we won’t be issuing a patch release immediately.

    As said in my previous reply, if you see the warning on the front-end of your site and not just in your log files, this is a configuration issue with your server. https://aristath.github.io/blog/wp-hide-php-errors is a helpful resource to help you resolve this.

    @tacoverdo after adding the code provided in the link above. The warnings are still coming.

    Please Update as soon as Possible. Because everyome is saying this error is occured after yoast update.

    So Yoast should resolve this issue

    @tacoverdo I have followed ur steps given in the Link https://kb.yoast.com/kb/how-to-check-for-plugin-conflicts/

    1. I have activated the health check plugin. I have enabled troubleshooting Mode. All plugins were disabled & theme switched to twenty Nineteen. I have Checked error logs the same error arises again.

    PHP Warning: Illegal string offset ‘width’ in /home4/s8l6zzck/opportunitiescorners.info/wp-content/plugins/wordpress-seo/frontend/schema/class-schema-image.php on line 149

    [30-Apr-2019 12:01:17 UTC] PHP Warning: Illegal string offset ‘height’ in /home4/s8l6zzck/opportunitiescorners.info/wp-content/plugins/wordpress-seo/frontend/schema/class-schema-image.php on line 150

    Again, then I have Enabled Yoast SEO Plugin Only. Then again the same error comes again.

    Now I have disabled troubleshooting Mode. and same errors happening.

    Its the issue with YOAST SEO ONLY. And Yoast Team should resolve this issue as soon as early.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    NOTE: If you are not saimrasheed then do not pile onto this topic. If you need support then per the forum guidelines please start your own topic.

    https://wordpress.org/support/forum-user-guide/faq/#i-have-the-same-problem-can-i-just-reply-to-someone-elses-post-with-me-too

    You can do so here.

    https://wordpress.org/support/plugin/wordpress-seo/#new-post

    I have archived the other replies. Please start your own topic rather than trying to hijack someone else’s.

    Plugin Author Taco Verdonschot

    (@tacoverdo)

    Thank you for troubleshooting @saimrasheed. That is indeed valuable information that I’ve now forwarded to our development team.

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.