Support » Plugin: Yoast SEO » Error after updating to Yoast Version 11.1

  • Resolved Jessica

    (@assimila)


    I updated Yoast today and am receiving the following errors on all pages:

    Warning: Illegal string offset ‘width’ in …/wp-content/plugins/wordpress-seo/frontend/schema/class-schema-image.php on line 149

    Warning: Illegal string offset ‘height’ in …/wp-content/plugins/wordpress-seo/frontend/schema/class-schema-image.php on line 150

    The issues are also present in error log files and present while in Troubleshooting mode with Yoast plugin enabled. They are not present when Yoast is disabled.

    Please advise.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Taco Verdonschot

    (@tacoverdo)

    Hi @assimila,

    Thank you for reporting this problem.

    We’re pretty sure we’ve found the source of the warning. Given that it’s just a warning, and nothing breaks on your website, we won’t be issuing a patch release immediately.

    However, if you see the warning on the front-end of your site and not just in your log files, this is a configuration issue with your server. https://aristath.github.io/blog/wp-hide-php-errors is a helpful resource to help you resolve this.

    I don’t believe it to be a server configuration issue since so many people are experiencing the same problem, and it only occurred after updating Yoast to v. 11.1. This issue was discussed in a previous thread.

    These warnings are visible on the website publicly and define(‘WP_DEBUG’, false);
    does not help, as this was already in place.

    I performed a health check and the issue persists in troubleshooting mode with Yoast enabled, but not when Yoast is disabled. It’s clearly a plugin issue that needs to be resolved quickly.

    I see this issue too on some pages on a site.

    Brandon Holcombe

    (@brandonhcreativemediacom)

    FYI.

    This helped me hide the error
    https://github.com/Yoast/wordpress-seo/issues/12811

    Thanks Brandon. I posted about it on there too and it’s now resolved. Appreciate your feedback.

    Este erro já esta sendo resolvido pelos desenvolvedores do plugin na versão 11.2.
    Por enquanto, têm-se 2 alternativas para resolver este erro:
    1º – No arquivo wp-config.php, substituir: define ( ‘WP_DEBUG’ , false );
    por: ini_set ( ‘display_errors’ , ‘Off’ ); ini_set ( ‘error_reporting’ , E_ALL ); define ( ‘WP_DEBUG’ , false ); define ( ‘WP_DEBUG_DISPLAY’ , false );
    Isso não afeta o site e forma alguma, apenas oculta para quem acessa o site os erros no mesmo, caso haja, pois, na maioria das vezes em hosts compartilhados baratos forçam a exibição de avisos e avisos do PHP.
    2º – Remover o logotipo do site das opções do Yoast SEO em: SEO > Aparência na Pesquisa > Geral (guia) > e deixa o campo “Organization logo:” da seção “Empresa” em branco.

    =========

    This error is already being solved by plugin developers in version 11.2.
    For now, there are 2 alternatives to solve this error:

    1 – In the wp-config.php file, replace:
    define (‘WP_DEBUG’, false);
    by:
    ini_set (‘display_errors’, ‘Off’); ini_set (‘error_reporting’, E_ALL); define (‘WP_DEBUG’, false); define (‘WP_DEBUG_DISPLAY’, false);

    This does not affect the site and any way, only hidden for those who access the site the errors in it, if there is, because most of the time in cheap shared hosts force the display of warnings and warnings of PHP.

    2 – Remove the logo of the site from the Yoast SEO options at: SEO> Search Appearance> General (tab)> and leave the “Organization logo:” section of the “Company” section blank.

    • This reply was modified 2 months, 3 weeks ago by  ewramartins.

    Hi Taco, unfortunately update 11.1 broke my website, no images and display pages only showing text etc … disabled yoast 11.1 and the website went back to normal.
    Any ideas? will you be doing another update soon as I have had to disable yoast for my website to function.

    • This reply was modified 2 months, 3 weeks ago by  downingp123.

    yes i feel that too

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.