Support » Plugin: Genesis Simple Sidebars » Error after updating to PHP 5.4

  • Resolved tditmore

    (@tditmore)


    My website host 1and1 required me to update to PHP 5.4. Before I did that, I updated WordPress to 3.5.1 and updated all plugins. Now I am getting these error codes atop all my admin pages:

    Warning: Illegal string offset ‘name’ in /homepages/7/d352737780/htdocs/wp-content/plugins/genesis-simple-sidebars/plugin.php on line 106

    Warning: Illegal string offset ‘description’ in /homepages/7/d352737780/htdocs/wp-content/plugins/genesis-simple-sidebars/plugin.php on line 108

    Sometimes–but not always–I get these codes instead of being able to pull up my website at all: http://www.editmore.com.

    I know very little about computer programming; the person who designed my site left the job where I had access to her, and I really don’t know what I should do to fix this. I saw a similar complaint on the larger WordPress forum, and the poster was advised to report this problem to the developers of Simple Sidebar, so that’s what I’m doing here. Please let me know how I can fix this problem.

    http://wordpress.org/extend/plugins/genesis-simple-sidebars/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    Check your wp-config.php & see if WP_DBUG is set to true. If so put // at the beginning of the line.

    I’ll make a note to have a look at the plugin.

    Sorry to be dense, but like I said, I know very little about this. Can you tell me where to begin to look for the wp-config.php?

    Plugin Author Ron Rennick

    (@wpmuguru)

    If you install WP manually you create wp-config.php. If your host installed WP for you then contact your host to ask for the location of wp-config.php.

    Hi Ron , Just thought I’d chip in as I have just set up a local test version of my website using EasyPHP and get the exact same error messages as tditmore (apart from the pathnames, obviously)

    Debug was set to false in my wp-config

    Live site server is running PHP 5.3.18 Local Servver is PHP 5.4.12

    If you want me to provide you with any other clues I’d be happy to help …

    Plugin Author Ron Rennick

    (@wpmuguru)

    @freestylemd – If it’s not in your wp-config.php then error reporting is enabled in your php.ini. You’ll have to look up where php.ini is located in your OS.

    I appreciate what you are saying, but switching off error reporting isn’t necessarily an ideal solution, although it will help while I am just making cosmetic changes to the website.

    I just realised that I have another website using simple sidebars on the same test server and that one works fine.
    What is different between the two is that the site which throws up the error message has a sidebar with an id of 0 which cannot be edited or deleted.

    I looked in the ss_settings field in the database and found that the first part of the field had

    a:5:{i:0;s:20:”__return_empty_array”; …. etc

    at the beginning, so I changed this to match a working sidebar setting and the errors have disappeared

    Plugin Author Ron Rennick

    (@wpmuguru)

    @freestylemd – thanks for reporting that back. The bug that created the bogus sidebar was fixed but some people still have it stuck in their settings.

    I a one who has IDs of 0 in a few installations of the plugin. It works fine using php 5.3 but breaks in php 5.4.

    Plugin Author Ron Rennick

    (@wpmuguru)

    The only way to fix it with the current plugin is delete the simple sidebar settings in the DB. Are you comfortable with doing that?

    You don’t have to delete everything though just

    i:0;s:20:”__return_empty_array”;

    and subtract 1 from the first integer after a:

    I am seeing the same problem.
    Any timing on a release of the plugin to fix it?
    Thanks

    I deleted __return_empty_array from ss_settings in the options table, and it got rid of the bogus “0” ID sidebar.
    Fixed… disregard the above I posted.

    I have the same problem with the error message. Where do I go to get to ss_settings? I tried following the error message and that led me to the plugin.php however there is nothing that looks like i:0;s:20:”__return_empty_array”;

    Nevermind I found the problem thanks

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Error after updating to PHP 5.4’ is closed to new replies.