Support » Theme: Customizr » error after updating to 3.2.9

  • Resolved neex01

    (@neex01)


    I got the following error when trying to access the site immediately after updating to 3.2.9:

    Fatal error: Call to undefined method TC_utils::tc_user_started_before_version() in /home/nchosfor/public_html/wp-content/themes/customizr/inc/class-fire-utils_settings_map.php on line 1243

    Error persists after deactivating all plugins.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Do you have this function in inc/class/class-fire-utils.php ?
    https://github.com/Nikeo/customizr/blob/master/inc/class-fire-utils.php#L693

    Theme Author presscustomizr

    (@nikeo)

    Hi, this looks like a WordPress server issue.
    It happened a few weeks ago on a previous update.
    https://wordpress.org/support/topic/fatal-error-missing-initphp-after-theme-update?replies=3
    According to @greenshady, this happens once in a blue moon with the WordPress.org system, and I have no doubts that he’s right, but I don’t see another explanation.

    Last time @otto42 identified that one of the servers had a bad copy of the theme.
    @otto42, if you get notified, would you mind checking if you get the chance ?
    Thanks

    Thread Starter neex01

    (@neex01)

    I deleted the existing copy of the theme and uploaded a new copy from the downloadable zip via FTP.

    Problem persists.

    Thread Starter neex01

    (@neex01)

    @d4z_c0nf,

    I do not have a “class” directory inside my “inc” directory. However, my class-fire-utils.php file is in the “inc” directory. The function appears to be there. I noticed in your link the function begins on line 694. My does in fact begin on line 693. Below is the code I have between lines 686 and 707 (inclusive):

    /**
    * Returns a boolean
    * check if user started to use the theme before ( strictly < ) the requested version
    *
    * @package Customizr
    * @since Customizr 3.2.9
    */
    function tc_user_started_before_version( $_version ) {
    $_start_version_infos = explode(‘|’, esc_attr( get_transient( ‘started_using_customizr’ ) ) );
    switch ($_start_version_infos[0]) {
    case ‘with’:
    return version_compare( $_start_version_infos[1] , $_version, ‘<‘ );
    break;

    case ‘before’:
    return true;
    break;
    }
    }

    }//end of class
    endif;

    Thread Starter neex01

    (@neex01)

    Also, FYI, I’m back up and running, but only after DOWNGRADING to 3.2.8.

    As the organization needs the site to be working during the day for the next week or so, I’ll need to do further testing at night from this point forth. So, while I hope to get some more suggestions here, please understand that I’m not being remiss if I take a day or so to reply.

    Thanks!

    Sorry, I wrote the path wrongly. It’s normal you don’t have a class directory 😀
    Don’t know what to suggest ’cause it seems a problem with your provider.

    Thread Starter neex01

    (@neex01)

    I just attempted to upgrade from 3.2.8 to 3.2.10. Same issue:

    Fatal error: Call to undefined method TC_utils::tc_user_started_before_version() in /home/nchosfor/public_html/wp-content/themes/customizr/inc/class-fire-utils_settings_map.php on line 1243

    If this is a WordPress server issue how should I proceed to fix?

    I am using Customizr theme for my site. I am trying to change the shape of the thumbnails from round to square, but it doesn’t work. I would also like to put a border around it. Can you please inform me how to make this happen

    I got same error when I update 3.2.8 to 3.2.10. But my website properly works after downgrade 3.2.8.
    I changed featured images layout from 3×1 to 3×3 in front page as below.

    $this -> fp_ids = array( 'one' , 'two' , 'three', 'four', 'five', 'six', 'seven', 'eight', 'nine' );

    in class-fire-init.php

    function tc_generates_featured_pages() {
          $default = array(
            'dropdown'  =>  array(
                  'one'   => __( 'Home featured page one' , 'customizr' ),
                  'two'   => __( 'Home featured page two' , 'customizr' ),
                  'three' => __( 'Home featured page three' , 'customizr' ),
                  'four' => __( 'Home featured page four' , 'customizr' ),
                  'five' => __( 'Home featured page five' , 'customizr' ),
                  'six' => __( 'Home featured page six' , 'customizr' ),
                  'seven' => __( 'Home featured page seven' , 'customizr' ),
                  'eight' => __( 'Home featured page eight' , 'customizr' ),
                  'nine' => __( 'Home featured page nine' , 'customizr' )
    			  ),
            'text'    => array(
                  'one'   => __( 'Featured text one (200 car. max)' , 'customizr' ),
                  'two'   => __( 'Featured text two (200 car. max)' , 'customizr' ),
                  'three' => __( 'Featured text three (200 car. max)' , 'customizr' ),
                  'four'   => __( 'Featured text four (200 car. max)' , 'customizr' ),
                  'five'   => __( 'Featured text five (200 car. max)' , 'customizr' ),
                  'six' => __( 'Featured text six (200 car. max)' , 'customizr' ),
                  'seven'   => __( 'Featured text seven (200 car. max)' , 'customizr' ),
                  'eight'   => __( 'Featured text eight (200 car. max)' , 'customizr' ),
                  'nine' => __( 'Featured text nine (200 car. max)' , 'customizr' )
    			  )
          );

    in class-fire-utils.php

    Do you have any idea?

    Thread Starter neex01

    (@neex01)

    Solved. I forgot I had a child theme for Customizr on this site. Activated Customizr, deleted (now inactive) child, updated Customizr, created new child, copied custom code from old child to new one.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘error after updating to 3.2.9’ is closed to new replies.