• Resolved justploddingalong

    (@clairedelune)


    I have just had to restore my website for the second time after updating to the latest version of W3 total cache.

    This time I updated every other plug-in and checked everything as I went through them one by one.

    What happens is that I updated W3 and then when marking comments as SPAM for bulk deletion the plug-in has caused an error that the database is damaged and displaying inaccurate numbers and not actually deleting the SPAM from the database.

    I don’t use Akismet because I can’t pay for it right now and this is a very disappointing thing to happen.

    Probably linked to hacker activities too. As a non-developer I have no idea where to begin to try and fix the problem ~ may all the blessings of the world shower upon the heads of those responsible.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Marco

    (@marcodiversi)

    hey,

    this thing is happening to me also with the latest update here: Version 2.2.11, since the previous one is doing it all the time.

    Since I am getting a lot of spam comments is also clogging my server , the errors that is throwing is this one:

    TypeError thrown

    call_user_func_array(): Argument #1 ($callback) must be a valid callback, class W3TC\Util_AttachToActions does not have a method “on_comment_status”

    Please fix it ASAP!

    thanks

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @clairedelune

    Thank you for reaching out ad I am happy to assist you with this.
    Can you please share if Database Caching and Object Caching are enabled in the General settings if so, please let me know which caching method you are using for these and does the issue persist if you disable those options.
    I’ve tried to replicate the problem and marked a bunch of comments as spam, however, I was not able to replicate this problem.

    Thanks!

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    @marcodiversi

     as a temporary fix please comment out line 33 of Util_AttachToActions.php

    //add_action( ‘wp_set_comment_status’, array( $o, ‘on_comment_status’ ), 0, 2 );

    Let me know if this helps!

    Thanks!

    Marco

    (@marcodiversi)

    @vmarko yes, this worked, thanks a lot!

    looking forward for an update!

    thanks

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @marcodiversi @clairedelune

    Thank you for the confirmation. This will be fixed in the next release.
    Thanks again for your patience.

    Thread Starter justploddingalong

    (@clairedelune)

    Thanks Marko and Marco.

    @vmarko To answer your question about chaching … Yes, to both Database and Object Caching. With all due respect I am not a developer and had a rough enough time of trying to get the backup restored; I will be waiting patiently for the properly implemented fix to become available in a future update.

    @marcodiversi thank you for the information about the problem that you also experienced.

    Thread Starter justploddingalong

    (@clairedelune)

    Just wanted to say thank you! Everything is working great again with the latest update.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error after update to version 2.2.11’ is closed to new replies.