Support » Plugin: Post Rotation » Error after Update Post Rotation to Version 1.5

  • Resolved audioguide

    (@audioguide)



    Hi … i want help

    I update first to WordPress 4.7.4 and after Post Rotation to 1.5.

    The result is:

    The plugin cannot be activated because it generates a fatal error.
    “Parse error: syntax error, unexpected ‘[‘ in /mnt/web221/c0/25/51624225/htdocs/ratgebergesundheit/wp-content/plugins/post-rotation/post-rotation-core.php on line 34 ”

    I want delete Post Rotattion and new install, but …
    “Delete failed: Internal server error”

    What can i do ????

    • This topic was modified 1 year, 7 months ago by  audioguide.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author digitalemphasis

    (@digitalemphasis)

    Hello.
    I suspect that you are using an old and unsupported version of PHP:

    http://php.net/supported-versions.php

    If so, then upgrade to a newer version of PHP or you’ll need to use an old version of the plugin.

    https://wordpress.org/plugins/post-rotation/advanced/

    Hope this helps.

    Sorry, not helpful.

    I have written that I have updated on WordPress 4.7.4, this is the latest version.

    Question: How can I “use an old version of the plugin.”

    I want delete Post Rotattion and new install, but …
    “Delete failed: Internal server error”

    Plugin Author digitalemphasis

    (@digitalemphasis)

    Ok, I’ll try to explain it better:

    You are using WordPress 4.7.4, today’s latest stable version but…
    what about the PHP version? Your hosting company will help you with this. More info here:
    http://php.net/supported-versions.php

    If you can’t/don’t want to use a most recent version of PHP (v5.6.x would be ok), then you’ll need to use an older version of my plugin:

    You’ll need to use FTP, then manually delete the ‘post-rotation’ folder into wp-content/plugins. This must fix your current issue.

    After that, download a .zip with an older version from here (a drop-down list at the bottom):
    https://wordpress.org/plugins/post-rotation/advanced/

    and proceed with the installation of the just downloaded .zip file. In example if your site is ‘your-site.com’, then go to:
    http://your-site.com/wp-admin/plugin-install.php?tab=upload

    Let me know if you succeed, ok?

    Just a head’s up, I encountered an error as well when I downloaded the plugin using WP 4.7.5. Here’s the error message;

    Parse error: syntax error, unexpected ‘[‘ in /usr/share/nginx/html/dining/wp-content/plugins/post-rotation/post-rotation-core.php on line 34

    I checked the file (via FTP) and saw the [ (brackets) but nothing looked out of place. Please advise.

    Plugin Author digitalemphasis

    (@digitalemphasis)

    Hello kredacter.
    The same applies to you: which version of PHP are you using?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error after Update Post Rotation to Version 1.5’ is closed to new replies.