Support » Plugin: IP Geo Block » Error after Update to newest version

Viewing 15 replies - 1 through 15 (of 18 total)
  • on some other pages which are at an other hoster I receive this error

    Warning: strpos(): Empty delimiter in /home/httpd/vhosts/xxx123.com/htdocs/cms/wp-content/plugins/ip-geo-block/classes/class-ip-geo-block.php on line 71

    hmmm…

    This seems to not affect everyone. I updated several sites this morning with iThemes Sync. One site I checked is OK, but another generated this error:

    Warning: strpos(): Empty needle in /home/habersha/public_html/wp-content/plugins/ip-geo-block/classes/class-ip-geo-block.php on line 71

    Warning: Cannot modify header information – headers already sent by (output started at /home/habersha/public_html/wp-content/plugins/ip-geo-block/classes/class-ip-geo-block.php:71) in /home/habersha/public_html/wp-includes/pluggable.php on line 1171

    I have the same error since updating. It would be nice if plugin authors actually tested their updates before launching them. This happens way too often and makes managing plugins difficult.

    Yes, you are right, but I think the author can’t not in all cases test all the different servers and adjustings.

    Hey, it’s free and a really good plugin, an the support is also great.

    But next time i really must test it at one server before I update all the others.

    KInd regards

    Free is good – and in this day an age you forget you’re working with free software 🙂

    I run a variety of servers and it’s down on all of them. I think it speaks to larger problems with WordPress – how to manage dozens or hundreds of WP sites effectively, like we do. Perhaps WP needs higher standards and more stringent procedures for plugin updates to keep this from happening.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear hai3009 and all,

    I should make an apology for having caused this trouble for all. I have just released fixed version 2.2.4.1. I would appreciate receiving your feedback.

    Whether free or not doesn’t matter for me. I really enjoy to contribute this community. But now the biggest issue for me is that I can’t provide alpha or beta version before I release every new version to get some feedback from my users.

    I’d like to think something about what jckuffner mentioned in the future.

    Thanks all.

    Anton

    (@anton-newpointdeviewcom)

    it’s working properly now
    Thank you

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Anton,

    Thank you for your quick feedback!

    Plugin Author tokkonopapa

    (@tokkonopapa)

    I want to say something just so there’s no misconception.

    Whether free or not doesn’t matter for me.

    I mean that I should not excuse myself because it’s free. I have learned a lot of things from this community, so I think I already have responsibility to provide good quality for 7000+ active users.

    But in fact, I can’t run a variety of servers. So I completely agree with @jckuffner.

    My idea is that it’s better to embed some components into the plugins to announce the call for voluntary testing.

    Thanks ever so much for the very quick fix. My site is geographically specific and was getting tonnes of hacker attempts from everywhere around the world. Your plugin has been a big time saver.

    After having my host disable (I think they could have only disabled this plugin – but they disabled ALL) – I just re-updated and it is working A O K!

    Thanks again for the quick fix.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Bawdidy1,

    Nice to hear that. Thanks for your feedback!

    Also at my hoster. I did re-install the plugin at all domains and now it is working like before. Next time I wait with an update for a few days 🙂

    But plugin is really great!!!!

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear hai3009,

    Thank you for your reporting about this issue. I should improve my development process to get your reliance 😛

    @tokkonopapa happy to help you testing for future releases. It’s a good plugin.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi jckuffner,

    Thank you for your kind offer! I would appreciate you if you check “Notify me of follow-up posts via email”. Then I can ask you to do me a favor.

    Thanks again!!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Error after Update to newest version’ is closed to new replies.