Support » Plugin: Popups, Welcome Bar, Optins and Lead Generation Plugin - Icegram » Error after update to 1.10.28 from .27

  • Resolved scubarob

    (@scubarob)


    Hi, after updating the plugin I get the following error:

    An error of type E_ERROR was caused in line 1248 of the file /home/bamboosc/scubarob.love/wp-content/plugins/icegram/icegram.php. Error message: Uncaught Error: Class ‘IG_Tracker_V_1_0_1’ not found in /home/bamboosc/scubarob.love/wp-content/plugins/icegram/icegram.php:1248 Stack trace: #0 /home/bamboosc/scubarob.love/wp-content/plugins/icegram/icegram.php(43): Icegram->include_classes() #1 /home/bamboosc/scubarob.love/wp-content/plugins/icegram/icegram.php(1856): Icegram->__construct() #2 /home/bamboosc/scubarob.love/wp-includes/class-wp-hook.php(286): initialize_icegram(”) #3 /home/bamboosc/scubarob.love/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /home/bamboosc/scubarob.love/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #5 /home/bamboosc/scubarob.love/wp-settings.php(394): do_action(‘plugins_loaded’) #6 /home/bamboosc/scubarob.love/wp-config.php(92): require_once(‘/home/bamboosc/…’) #7 /home/bamboosc/scubarob.love/wp-load.php(37): require_once(‘/home/bamboosc/…’) #8 /home/bamboosc/scubarob.love/wp-admin/admin.php(34): require_once(‘/home/bamboosc/…’) #9 /home/bamboosc/scubarob.love/wp-admin/plugins.php(

    Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’m having an issue with the plugin as well after updating.

    I disabled the plugin and my website works again.

    [30-May-2019 14:07:53 UTC] PHP Fatal error: Uncaught Error: Class ‘IG_Tracker_V_1_0_1’ not found in ~/public/wp-content/plugins/icegram/icegram.php:1248

    Hello,
    I have the same problem but I cannot even reach the admin site… how did you disable it?
    Thanks in advance.
    Tamas

    You have to do it by FTP

    Go to your website’s directory and navigate to the plugins section

    Should be something like

    yoursite/wp-content/plugins/icegram

    When you get there, rename the Icegram plugin folder to icegram-disabled

    This will disable the plugin, and if you need to reactivate it, just go and remove the -disabled from the end of the folder name.

    Plugin Author Icegram

    (@icegram)

    Hi,

    Sorry for the inconvenience you had.

    We have just released 1.10.28.1 which should fix this issue.

    I updated the plugin – still totally breaks my site.

    Edit to clarify: The admin dashboard works with the plugin activated now (didn’t before) – but the frontend is still “experiencing technical difficulties”

    • This reply was modified 6 months, 1 week ago by theresmorgan.
    Plugin Author Icegram

    (@icegram)

    @theresmorgan Sorry for the inconvenience.

    Backend was fixed but frontend was not fixed.

    Just fixed it and released 1.10.28.2.

    Please upgrade and check once again.

    Plugin works again across the board.

    Thanks for the quick fix!

    Thanks @theresmorgan, unfortunately it tells me that I don’t have access (I use some secret log in). @icegram for me none of them (backend, frontend) work

    You will need to access the site through FTP/Cpanel and edit the folder directly @ntkajak – Your dev/admin will have access to this (although if you’re the owner, they really shouldn’t be locking you out)

    Unfortunately I never used FTP/Cpanel (and I created the site), only the wordpress admin page. I still get the same fatal error message when I load my webpage.

    You won’t be able to fix this from the admin page, you’ve got to use a file manager like mentioned above.

    Wherever your website is hosted SHOULD have ftp/cpanel access for your site. There are a few “wp hosts” that don’t allow access, but this info really should be somewhere.

    It’s a really quick fix – if you’re stuck, add me on skype at morgancrozier and I can help you through it.

    @theresmorgan thank you. I will try to fix it there, so I don’t wait that the update will automatically fix it. Never happened something like this, I would expect that they test all the updates before releasing…

    @theresmorgan I found a webftp at my host and renamed the folder, it was very easy (just never had to use it so far…) and it worked 🙂 Thanks a lot for your help, you saved lot of time for me!

    No problem! I’m glad to hear it’s worked out. @ntkajak

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Error after update to 1.10.28 from .27’ is closed to new replies.