Support » Plugin: Mailjet Email Marketing » Error after update

  • Resolved m290591

    (@m290591)


    Hello, following the update I have an error.
    I had to deactivate the plugin.

    Path error on ‘/src/includes/MailjetMail.php’ line 27

    require_once ABSPATH . WPINC . '/PHPMailer/PHPMailer.php

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same here after updating to the latest 5.2.2 Plugin release from the last Plugin update.

    [28-Jul-2020 21:56:28 UTC] PHP Warning: require_once([…]/wp-includes/PHPMailer/PHPMailer.php): failed to open stream: No such file or directory in […]/wp-content/plugins/mailjet-for-wordpress/src/includes/MailjetMail.php on line 26
    [28-Jul-2020 21:56:28 UTC] PHP Fatal error: require_once(): Failed opening required ‘[…]/wp-includes/PHPMailer/PHPMailer.php’ (include_path=’.:/opt/bitnami/php/lib/php’) in […]/wp-content/plugins/mailjet-for-wordpress/src/includes/MailjetMail.php on line 26

    Auto-updating of the plugin leads to the fatal error.
    (needs the plugin folder to be deleted to re-access wp-admin and site)

    Re-installing the plugin leads to the fatal error and doesn’t let the plugin get activated.

    To fix the problem quickly you will have to update two lines in
    wp-content/plugins/mailjet-for-wordpress/src/includes/MailjetMail.php line 26 and 27 :

    require_once ABSPATH . WPINC . '/class-phpmailer.php';
    require_once ABSPATH . WPINC . '/class-smtp.php';
    

    PHPMailer classes are in the root of wp-includes/ folder in WP 5.4.2, but futur version of WordPress will update PHPMailer to a newer version and it will be in wp-includes/PHPMailer/. Seems like the update of this plugin have been done before the new release of WordPress.

    • This reply was modified 2 months, 3 weeks ago by prometee. Reason: format
    • This reply was modified 2 months, 3 weeks ago by prometee.
    • This reply was modified 2 months, 3 weeks ago by prometee.
    Gilles

    (@alizesonline)

    Same problem. The PHPMailer.php file is not at the place the plugin is looking for it, which causes a fatal error and makes the website crash completely.
    I reverted to the version 5.2.1 from a backup. That fixed the problem by the time the editor publishes a new debugged release.

    Thanks @prometee it works like a charm !
    Just need to wait for the plugin fix.

    @mailjet this Plugin needs an urgent Plugin update to restore it on w.org

    Plugin Author Mailjet

    (@mailjet)

    Hello,
    Sorry for the inconvenience, a new version has been pushed and should fix the issue. You will be able to get it as soon as the plugin will be reactivated.
    We are currently working on a version that will be compatible with WordPress 5.5 and previous versions. The release will be available in the next few days.

    @mailjet , only 5.2.2 is available from github … https://github.com/mailjet/wordpress-mailjet-plugin-apiv3/releases
    I suggest you post your fix there “now” …

    Plugin Author Mailjet

    (@mailjet)

    Hey everyone,

    The plugin is back online: https://wordpress.org/plugins/mailjet-for-wordpress/.

    Thanks again for your patience and we apologize for the inconvenience.

    Cheers 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.